0

I have a 13" 2011 MacBook Air A1369 stuck on a grey screen. When I startup I can hear the chime and the computer proceed to go to a blank gray screen immediately. The screen has no Apple logo or loading bar.

What I have tried till now:

  • Booting in recovery by holding Command + R -- no effect, blank screen.

  • Booting in single-user mode by holding Command + S -- no effect, blank screen.

  • Booting in verbose mode by holding Command + V -- no effect, blank screen.

  • Booting in Safe mode by holding Shift -- no effect, blank screen.

  • Booting in hardware diagnosis mode by holding D -- no effect, blank screen.

  • Resetting PRAM by holding Command + Alt + P + R -- no effect, blank screen.

  • Resetting SMC by holding Shift + Alt + Control while pressing the power button, then pressing the power button alone -- no effect, blank screen.

  • Choosing another booting drive or recovery partition by holding Alt -- no effect, blank screen.

Is there something else I could try to get past this gray screen?

  • 1
    Looks like you have tried pretty much everything. Unfortunately it may be time to take it to an Apple Store or other trusted local hardware service center. – Steve Chambers Apr 22 at 18:20
  • Is it possible that a broken SSD might be the problem? looks weird that all the combination keys does nothing, maybe a broken keyboard? – F S Apr 22 at 18:24
  • Absolutely. One of the possibilities. It could be more extreme (bad mobo) or less (loose connector, bad cable). However recovery mode does not boot from the drive, that's all in NVRAM. So if it was just an SSD issue then recovery mode would work and you would not have a target to install to. Yes a bad SSD could be hanging the entire system and preventing any kind of boot, but that will still require diagnosis of the hardware. – Steve Chambers Apr 22 at 18:29
  • I understand, i have already tried without SSD, makes no difference, external video output same blank screen, is it possible a corrupted BIOS? – F S Apr 22 at 18:35
  • ANYTHING is possible at this point. Take. It. In. For. Service! – Steve Chambers Apr 22 at 19:18
1

I have found the problem, the BIOS firmware was badly corrupt from a failed macOS update, i had to fix it hardware removing the BIOS chip and flashing it again, now it's working perfectly!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .