0

Our office iMac is set to restart every night and it has an admin account and a user account. This is a fresh install of 10.14.4 which we have just reinstalled.

I logged into the admin account and enabled internet sharing (from Ethernet to Wi-Fi). Then logged out of admin and into user account.

When the user logs in (automatically, as a result of restart) the Wi-Fi will not be shared. (This is noticeable because all the TVs in our office say Chromecast can't find Wi-Fi.) If the user will open settings then it shows that internet sharing is enabled (green color) however the Wi-Fi icon in the menubar will show a disconnect Wi-Fi symbol rather than the expected Wi-Fi is sharing symbol.

The workaround is that each morning I will open system preferences->networking, unlock as admin, disable internet sharing and then enable internet sharing.

I am seeking to remove this required workaround.

  • 2
    Your best bet is to not use the iMac as a permanent WiFi router. Get a proper router with WiFi so you don’t have this issue – Allan Apr 22 at 16:03

You must log in to answer this question.

Browse other questions tagged .