1

Recently Safari has gotten into a mode where unwanted events are happening. Pages I'm viewing will randomly zoom in with no known way to zoom out. Pages will also "slide" off the app by sliding finger across mouse.

I've tried restarting Safari and I've tried restarting my computer. Neither of these helped. I have a "Zoom" extension for Safari but I've turned it off.

2

Sounds like you have system zoom enabled. You can disable it from System Settings > Accessibility > Zoom.

When you have system zoom enabled, you can toogle it with cmd-opt-8, or use your control gesture which is by default the ctrl button in addition with the scroll gesture (i.e. sliding your finger across the mouse as you mention, or using the scroll wheel on a mouse).

Regarding Safari it seems like you're not aware that you have gestures enabled. If you go to System Settings > Trackpad or System Settings > Mouse according to what you use, you can see the gestures that are enabled. Check for "More Gestures" and you'll see that for example "Swipe between pages" will look like pages just "slide off Safari", where you're really just navigating back/forth in the history using gestures.

  • Thanks for your answer. I've turned off zoom. If this works i'll be sure to accept you answer. – jmh Apr 21 at 19:44
  • Your answer didn't work although it seems to have helped. I'm still getting occasional zoom-ins and web pages that swipe right completely off Safari. – jmh Apr 23 at 15:23
  • @jmh I have updated the answer - you seem to have also enabled gestures on your mouse/trackpad. Check for that, I'm pretty sure that's what you see in Safari! – jksoegaard Apr 23 at 16:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .