1

I've worked this problem w Apple Mac L2 across two phone calls lasting a total of 5 hours and escalation to L3 without a possible resolution, hence opening up my search to the world.

My ask:

What are the step by step instructions to delete a disk image called "mac OS Installer" that was left during a irrevocably failed 14.3 to 14.4 upgrade? Please see the context and timeline below...

Ultra condensed sequence of events starting Wed, Apr 17:

  1. The 14.3 to 14.4 upgrade is supported through multiple reboot sequences, and between reboots 1 and 2, the update became irrevocably damaged (long unresolved story w L2 and L3 as to how they believe it happened based on my step by step explanation).
  2. The result is a lingering disk image called "mac OS Installer" that's only visible when booting w Startup Manager. This means that Disk Utility, "About this Mac - Storage", Recovery OS, and Internet Recovery OS cannot see my main "Pro6GSSD" as they all permanently hang on "Locating disks". Additionally, 3rd party utilities such as CCC (loads, but does not see Pro6GSSD) and Stellar Data Recovery never gets past the splash screen w a moving "Initializing..." (see screenshot below).

Current status and how I worked around the problem:

  1. I can boot my partially updated and totally unreliable 14.3 image (Pro6GSSD) using Startup Manager, however it's no longer a quality production environment.
  2. I bought another 1 TB SSD and replaced my existing optical drive in my MacBookPro9,2 w a Data Doubler (DD). The new SSD (mojaveOS) went into the main drive bay and the now damaged SSD (Pro6GSSD) is in the DD. Note: both the main and optical bay's SATA are 6G, and both SSDs are identical 6G's.
  3. Installed a fresh 14.4 on the new SSD (mojaveOS) and recovered my data from my cloud based backup service - thankfully, no issues

  4. Because of what I explained in #2, I cannot reformat my original SSD (Pro6GSSD) that contains the "mac OS Installer" image that now resides in my DD as I plan on using it (Pro6GSSD) for backup and other dev/test work.

Here's the evidential view of "mac OS Installer" from Startup Manager enter image description here

Here are the diskutil list and Disk Utility from the fresh 14.4 (mojaveOS) environment... notice the similar behavior for both the diskutil list command does NOT return to the command prompt, AND that the Disk Utility is permanently hung on "Locating disks"... The last screenshot is from step #2 (above) where Stellar Data Recovery gets permanently hung during initialization similar to Disk Utility. enter image description here

enter image description hereenter image description here

here are the screenshots from the diskutil and Disk Utility from the damaged 14.3 (Pro6GSSD) environment via Startup Manager boot... notice that diskutil list returns to the command prompt upon completion enter image description here

enter image description here

  • if you add the results of "diskutil list" to your original question that may give our disk experts the clues they need to diagnose your issue. – Steve Chambers Apr 21 at 16:27
  • Ty Steve... here it is... – jeff trbovich Apr 21 at 16:47

You must log in to answer this question.

Browse other questions tagged .