0

I have a Mac Mini 2014. I just installed a second SSD drive Samsung Evo 500GB and would like to use as the primary drive for OS.

I formatted both drives with disk utility to OS Extended Journaled and clicked install Mojave but got this error.

If I format the drive as APFS, the installation starts but after the restart, I get a blinking folder with a question mark. If I try to install from an external USB, instead of the folder with a question mark, I get booted into Recovery again instead of continuing the installation process.

Any ideas?

1

Try to install on the old disk first, to see whether there is a hardware issue with your new disk, for instance by copying a lot of files to it. You can also then install a second copy of your OS to the SSD and see where it fails.

Once both work, if you boot with ALT and press CTRL, it will save the ssd you are booting to as default.

  • Indeed, I was able to install osx on the older disk, but I am still unable to install anything on the new disk. I keep getting the same Apfs conversion error, or if I convert it myself, installation boots into recovery, rather than continuing. The disk is brand new and I am able to format it and partition it, so it doesn't look faulty. Could it be that Apple only allows OSX to be installed on the primary internal non-SATA drive? – mgPePe Apr 21 at 13:33
  • No, You can usually even install it on a usb stick. I think there is some issue. If you can, try to install the OS from another Mac (maybe in the store where you bought the ssd). Target disk mode should work here, no need to disassemble your Mac. Alternatively, you can also install an older version of OS X and then convert to APFS. Shift-Alt-Cmd-R should load a recovery where the older OS is available. – Carl Dombrowski Apr 21 at 13:43
  • I tried installing an older OSX - it doesn't work. Gives me this forbidden sign - circle with a diagonal line – mgPePe Apr 21 at 13:57
  • Is the ssd in HFS format? If yes, there is a hardware issue with your ssd. You can try to change the cable connectors, in case there is something with primary disk or such I'm not aware of. Or you can put it in an external enclosure. But I assume a broken SSD. – Carl Dombrowski Apr 21 at 14:13
  • I tried both HFS and Apfs. The problem seems to be in the booting. I can install things and copy to it, but after the initial transfer of information neither windows nor osx can boot into it to continue setup... – mgPePe Apr 21 at 14:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .