5

When I go to a site that has a password saved and I select the password, Safari attempts to log me in immediately. However, this completely breaks functionality on some websites (ex adding accounts to RES etc). I believe this "feature" was added recently (10.14.4?).

I was able to disable requiring Touch ID to log in, which is a step in the right direction, but I want to disable the auto login completely, while still autofilling passwords. Is this possible/how can I do it?

  • As a workaround, you can turnoff password autofill in Safari preferences-> Passwords. And then copy paste password from the Passwords. This can be used as long as they don't offer a solution. Another way can be to remove the username from that particular website's password entry. A partially filled form (maybe) won't be submitted. Password will be autofilled and username will await. – ankiiiiiii Apr 21 at 15:30
0

Background

Unfortunately it looks like Apple decided to change this behavior in Safari, at least according to this article titled: Safari: macOS browser now autosubmits logins. Here’s how to disable it:

Apple changed the behavior of Safari in macOS 10.14.4, and you may have noticed it and thought it was a bug. Now, if you have stored a password for a website, when you select a login entry to autofill, Safari 12.1 for macOS automatically submits the login. Previously, it would fill the fields and still require you to click a Login or Submit or other button to proceed.

Apple mentions it here in their Mojave 10.14.4 Update release notes (2nd bullet):

Safari

  • Adds Dark Mode support for websites that support custom color schemes
  • Streamlines website login when filling credentials with Password AutoFill
  • Allows push notification prompts only after interacting with a website
  • Adds a warning when an insecure webpage is loaded
  • Removes support for the expired Do Not Track standard to prevent potential use as a fingerprinting variable; Intelligent Tracking Prevention now protects against cross-site tracking by default

Workaround

So it looks like your only recourse here is to disable auto fill under the "User names and passwords" section of the AutoFill tab of Safari's preferences.

AutFill tab under Safari Preferences

ss1

Edit under User names and passwords

ss2

NOTE: That dialog is actually just the Passwords tab, so you can just navigate to it directly.

  • 1
    Sorry, maybe I wasn't clear. I don't want to turn off autofill, I want to turn off autologin. I still want the passwords to be autofilled, otherwise there's really no point to saving passwords. I just want a return to the functionality that existed before the update. – WhyIsItReal Apr 21 at 20:14
  • @WhyIsItReal - sorry I didn't explain this better, I've updated my A'er. What you're asking cannot no longer be done in Safari, unfortunately. – slm Apr 22 at 2:32
-1

Or you could just Private Browse.

This stops the auto logging in functionality but leaves the passwords you have for any particular site. This seems to work when I have multiple logins for each site under different email addresses. This does seem to halt the auto login process

The downside, your website history is not recorded. Though that may be a good thing?

  • No. In private browsing too it auto logs me in. – ankiiiiiii May 31 at 5:54
  • So sorry. Seems to work on mine. Maybe it's a on a site by site basis? Or it could be an extension I have that you don't? I have ghostery and ad block loaded. Tried quite a few of the sites I need to log into and it certainly does not auto log me in via Private mode for me. – Anony Mouse Jun 1 at 6:11
  • OK Thought of another thing that I seems to have on most of the websites I have tried. I have multiple log ins for each site under different email addresses. This does seem to halt the auto log in process. – Anony Mouse Jun 1 at 6:17
  • Please incorporate this info into your answer, I would be able to remove my downvote. I also have Ghostery installed. The multiple login is reasonable. – ankiiiiiii Jun 1 at 6:37
  • No,the multiple email addresses theory in private mode is not working. As soon as a password is selected, it submits the form. On some sites where the website itself stops this from happening like behance, it might work but that is a coincidence. – ankiiiiiii Jun 1 at 20:44

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .