0

So I have Messages in iCloud enabled on my iMac - High Sierra, 10.13.6. My iPhone - version 12.2 and iPad - version 12.1.4. The issue id like to solve is this - on the iPhone an iPad when I delete a message, I get the warning / confirmation that if I delete a message it will delete across all devices, do I want to delete? When I answer yes, the message will delete from the iPhone and iPad but not the iMac. When I go to delete a message on my iMac, I get no prompt / confirmation, the message will just delete. I have sent numerous logs to apple, enabled a pin code for them to rest my iCloud account and sent them some sort of profile info, but they have been unable to get my messages to sync when deleting across all the devices. I have also disabled and re-enabled iMessages in the cloud on all devices with no luck.

Can anyone help me to get the iMessages deleting across all devices? I am almost certain it did work properly at some point, but started this after an update. Sorry to not be more specific on what I did with apple, but I did not write down all the info - but they have collected a lot of info and I do not remember for 100% sure when it started to act up. This has been ongoing for awhile now and they just won't respond any longer. Tks much!

1

So I tried again with another apple senior advisor today as the previous one would never do what he said he would. I think the issue is solved.... Heres a screen shot of what she had me uncheck in the Messages preferences tab on the iMac and the messages are all now acting the same in syncing...

enter image description here

  • Please close the question :) – ankii May 30 at 18:46
  • So I searched in help, “how to close a question” and got 84 results - mine on how to close a question. I thought it was closed when marked as answered. Sorry. How do I close it? – Stumped May 31 at 13:02
  • I assume you logged in. Below the inverted triangle under "1" beside this answer, you should see a greyed tick mark. Press on it. Should go green and you will gain 2 reputation. – ankii May 31 at 14:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .