0

I know this question has been asked before but none of the answers worked for me.

I have tried three different brand new SD cards, 2 San Disk's and one Samsung's, using both MacBook's built-in SD card reader and a USB card reader, but the SD card doesn't show up in Finder, Disk Utility, Image Capture or Terminal (ls /Volumes/). It does show up in System Report which hints that there's some problem with the software and not the hardware. The same is mentioned by San Disk here:

I have tried upgrading to macOS Mojave from macOS High Sierra, but to no avail. These SD cards don't show up in Linux either. An older SD card of mine does show up in macOS/Linux. So I am guessing that the new SD cards are missing something, some kind of a driver? Does anyone have any idea what could that be?

  • Welcome to Ask Different :) Are you sure the SD card themselves are not the culprit? As you mentioned that the card(s) in question didn't show up on a laptop running Linux, it raises question on the card itself. Make sure the card(s) is working on some other computer before questioning hardware/software of your computer. – Nimesh Neema Apr 19 at 13:47
  • It's a possibility but it's three different SD cards from 2 different brands. They can't all be corrupt. San Disk's website says that if the card are visible in System Report, that hints of a software problem. – Beenish Khan Apr 19 at 13:55
  • It would help if you can edit the question and share the link to the article claiming so. If San Disk claims it be to a software issue, they must have some resolution steps as well. – Nimesh Neema Apr 19 at 13:57

You must log in to answer this question.

Browse other questions tagged .