1

I ripped a perfectly fine SSD out of a Macbook with a broken display.

So far, all my attempts to access the file system on the SSD have failed.

  1. I've tried to put in a nearly identical Macbook. This Macbook booted into recovery mode but I was unable to access the SSD's filesystem from there. (Specifically, following this answer didn't work as the output of diskutil list does not include any lvUUID)
  2. I've tried to boot from the SSD on the nearly identical Macbook. The SSD isn't even an option in the boot menu.
  3. I've connected the SSD via a USB to SATA connecter to my main computer. I am still unable to mount the SSD as the option for "mount" in disk utility is greyed out.

Note: I need to access this SSD so that its files have names. While programs like photorec will recover data from the SSD, they will give the files random names i.e. f2839048.png.

How do I mount this SSD so that I can browse it normally?

Edit 1:

Here's the output of diskutil list on my new Macbook. The SSD in question is hooked up externally.

   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                         121.3 GB   disk0
   1:                        EFI EFI                     314.6 MB   disk0s1
   2:                 Apple_APFS Container disk1         121.0 GB   disk0s2

/dev/disk1 (synthesized):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      APFS Container Scheme -                      +121.0 GB   disk1
                                 Physical Store disk0s2
   1:                APFS Volume Macintosh HD            72.5 GB    disk1s1
   2:                APFS Volume Preboot                 45.6 MB    disk1s2
   3:                APFS Volume Recovery                522.7 MB   disk1s3
   4:                APFS Volume VM                      4.3 GB     disk1s4

/dev/disk2 (external, physical):
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *250.1 GB   disk2
   1:                        EFI EFI                     209.7 MB   disk2s1
   2:                  Apple_HFS Macintosh HD            249.2 GB   disk2s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk2s3

disk2 is the SSD that I'm having trouble accessing.

Edit 2:

The SSD was indeed corrupted. I ended up using Photorec to get all relevant files and sifted through them to get what I needed.

  • From which specific Macbook model did you remove the SSD? Is it FileVault-encrypted? In option 1, did the Mac at least see the disk? – nohillside Apr 19 at 11:25
  • The SSD is from a 2009 Macbook pro. Yes, the MacBook sees the SSD in option 1 as "disk0". My new MacBook in option three also recognizes the drive as an external SSD but the option to mount it is greyed out. – Cat Apr 19 at 12:45
  • Can you run diskutil list against the drive? – nohillside Apr 19 at 12:58
  • I updated my question with the output of diskutil list. – Cat Apr 19 at 15:16
0

If diskutil mount /dev/disk2s2 doesn't work, then I'd suggest the SSD is faulty, and you will need to use data recovery software, which will rarely give you the filenames and folder structures.

Backup?

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .