So I have a jailbroken iPad on 4.X. I would like to use the new Netflix interface but it's only for ios 5. Is there any jailbroken app that will make it think its on ios 5 and not ios 4.X? Or is possible to edit the Netflix app files or something? Thanks for the help.

  • Do you consider this question to be unanswered? If so, could you explain how I could make my contribution better? Commented Oct 18, 2013 at 19:20

3 Answers 3


Even if you could fool the app, it would crash as soon as it called on a part of the system that exists in iOS 5 but not in iOS 4. Your editing of the file would both have to be the main version requirements check as well as any internal checks that the app makes to determine the capabilities and API present on that device as the program runs. I don't know any developer that just said they need iOS 5 out of spite against people running 4, 3, 2 versions of iOS. It's always been because they need features and code frameworks added in iOS 5 and couldn't code around it in the program. When a developer can do that, they change their app to work on multiple os versions and let you know feature X is disabled or works differently when running on iOS 4. For developers that want to use the latest tools in iOS, it is actually more work for them to keep the older OS support in each build so there needs to be a good financial reason to keep doing that work in many cases.

Think of the iOS version test as sealing a door to nowhere opening up on the third floor of a building when the fire escape stairs (or balcony or whatever) is not yet built. When the program you deceive into thinking it's running on iOS 5.x calls on code that doesn't exist, the app will crash.

Apple designed the version check to "lock the door or perhaps the entire wing of that building" in a very visible way. By bypassing this check, it's like removing the "danger / hazard" signs and nailed wood braces covering the opening and letting someone walk out into thin air from that third-floor door to nowhere.

  • 3
    Good analogy! :) Commented Jan 6, 2012 at 5:13

I've done this before, and it caused a bit of instability, but all you need to do is open /System/Library/CoreServices/SystemVersion.plist in iFile, find where it says iOS version 4.X, and change it to 5.0.1. This will allow you to download any app that requires iOS 5.

  • Wow - that's a fairly simple change to make - Would you consider editing this to report what percentage of apps seem to run in daily practice when you override a version 4 system to say that it is really version 5.
    – bmike
    Commented Feb 14, 2012 at 1:17
  • 4
    I just tried it on my friend's iPod running 4.3.3 and spoofed to iOS 5.0.1, and all the normal apps worked, and the AppStore let me download iOS5-only apps, but those apps crashed. We didn't want to ruin his Netflix app, so we tried on Find My Friends and a random app that required iOS5. They both installed just fine, but crashed upon opening them. I wouldn't recommend doing this, but I hope this answers your question to your satisfaction. Commented Feb 14, 2012 at 4:14
  • 1
    Awesome - your answer is great - especially with the caution that things aren't expected to work. +1 indeed - you've been a great asset answering jailbreak questions - thanks for fielding them.
    – bmike
    Commented Feb 14, 2012 at 4:42
  • I tried editing /System/Library/CoreServices/SystemVersion.plist and all I got when I went to the app store was a grey screen. When I changed back the version to 4.3.3 I still get the same grey screen so effectively my App Store (and iTunes) are broken.
    – g0nY
    Commented Nov 12, 2012 at 19:23
  • Interesting. I'm sure you've tried all the usual things to fix it: closing out the app manually, respringing, and rebooting; right? If you have, and it's still having problems, then there might be something else at play, because it reverted just fine when I tried it myself. I believe my friend is still running 4.3.3. I could try to reproduce your issue if you'd like. Commented Nov 18, 2012 at 2:57

Deleting /System/Library/CoreServices/SystemVersion.plist solved the problem for me. There's no guarantee what will happen if you delete your /System/Library/CoreServices/SystemVersion.plist but it seemed to work for me on iOS4.3.3(8J2) to fix the issues I was having as mentioned in the previous post.

I don't recommend spoofing the iOS version in SystemVersion.plist as it would appear that the new App Store is not compatible with iOS 4.3.3.

  • This isn't really an answer to the question. It should have been kept as a comment on the other answer. I personally tried this myself on iOS 4.3.3 as mentioned before. The AppStore worked just fine, and it let me install apps. I believe the issue that you were experiencing wasn't really what you thought it was. All you have to do when the AppStore turns blank is click on the icons at the bottom. Click the same one twice. Commented Dec 5, 2012 at 19:24

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .