SDcard from Raspberry pi 0 has several text files (and python scripts) which do not show up when mounting on internal mac SD reader. How can I recover those files?


The Pi likely formatted the filesystem as a Linux ext4 filesystem.

Type cat /etc/fstab and check the filesystem type of your / partition (look to see if it says ext4).

You can enable ssh on the Pi and use scp to copy the files across to your mac. You can use sudo raspi-config on the Pi, go into the "Interfacing Options" menu and enable ssh.

You could install ext4 filesystem support on the Mac to make it possible to mount the sdcard. To do this, you would install FUSE for macOS and make sure you install the ext4fuse filesystem handler.

There are numerous articles that walk through the steps required. Here is just one example: https://www.jeffgeerling.com/blog/2017/mount-raspberry-pi-sd-card-on-mac-read-only-osxfuse-and-ext4fuse

  • Thanks Tim! Tried JeffGeerling's blog--worked fine for the boot part. y'day, but not the Recov. part until today... after another reboot. Looks like I'm on the way. :-) – Stefan Apr 18 '19 at 0:53
  • Is it easy enough to edit the answer with the steps you used? – dwightk Apr 18 '19 at 2:08
  • ok,,, as best I recall. – Stefan Apr 19 '19 at 4:01

ok,,, as best I recall. begin with Jeff Gerrlings link above. I discoverd that the RECOVERY partition(?) is just for that only; so I ext4fuse'd the boot disk. Had to hunt for the pi home directory and found the py-scripts in the 'media' directory. Opened another terminal to find the right target location. Copied the py-script files with 'cp /Volumes/rpi/home/pi/media/filenames* /Users/mylogin/etc/etc/'

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .