0

Guys I'm running out of steam here... how do I copy files from a hard drive in recovery mode to an external hard drive on an older mac.

First few things I did: boot into recovery mode and run the normal first aid, and it failed, so I reset the ram by holding down command and option p r and that didn't work.

It breaks down into 3 errors:

  • incorrect number of thread records

  • incorrect number of extended attributes

  • incorrect number of access control lists

I ran a bunch of commands to fake the mounting of the disk so that it would appear non-greyed out in the disk utilities in recovery mode, from there I was able to confirm that all of the files were still there by parsing through the image. However I was unable to extract those files, due to in part never running said mount command on the hard drive in question, I think this is why? Also should be noted that I cannot make a copy of the disk image for a specific folder (user folder) after I run my diskutil verfy and repairs...

I was able to run fsck_hfs -drfy /dev/disk0s2 many times, it did nothing

however fsck_hfs -drfy /dev/disk20 gave me the information I needed but couldn't act upon. I noticed that when it was trying to repair there were a few threads that were continuously failing and by running. By seeing the threads that are failing to run I was able to do a search on the file systems and figure out that the corrupted files were inside the .Spotlight-V100 folder.

Thread ids relating to corrupted files

14608902
14608932
14608904
14608919
14608919
14608939
14608909
14608971
14608938
14609018
14608944
14608923
14608941

by running this command I can find where those files live find / -inum 14608902

in this folder: /Volumes/Macintosh HD/.Spotlight-V100/../../..

From here I tried running -rm and it failed to run this, saying everything was read only.

I also tried running -cp <path> <extrenal hard drive> to copy all of the contents of the files that I was still seeing however, I would simply get a Directory not found error.

So I thought it might have been due in part to permissions so I ran a -chmod 755 on all of the root folders of botht the external hard drive and the one I was trying to pull all of the data from.

I can boot into recovery mode and single user mode, however I cannot boot into safe mode. Also just to confirm the -diskutil mount /dev/disk20 failed as well.

So I have a hard drive where I know the issues are, have run a lot of utilities on them, can confirm the files exist but cannot for the life of me extract the files off of it or delete the corrupted files. Any thoughts?

You must log in to answer this question.

Browse other questions tagged .