0

I use XQuartz 99.9% of the time I'm on my Mac. When I lock my screen (using Lock Screen in the apple menu) -- or the screen saver kicks in -- and the screen remains locked/darkened for more than a few minutes -- not sure what the minimum amount of time is for this -- the screen background is often black when I unlock the screen or wake up the display. I am still able to see and use everything on the desktop -- mac icons, mac apps, X window apps, etc. -- but the screen background is black -- really hard on the eyes! If I exit XQuartz, my screen returns to normal but this is not a solution since I then lose all my X applications. If I lock the screen and immediately unlock it, I don't see the problem.

I'm running macOS High Sierra (10.13.6) and XQuartz 2.7.11. I have had my Mac (it's a work mac) since May, 2017. The Mac came with Sierra and I installed High Sierra early last fall but did not start having this problem until January. It mysteriously went away for a few months but has now returned.

Any ideas or suggestions? I'd be happy with a reasonable workaround that doesn't involve killing XQuartz.

  • Have you tried going to System Preferences and setting or changing your desktop? – jmh Apr 17 at 1:49
  • I just upgraded to Mojave, The problem has not reoccurred. If it does, I'll try your suggestion. – rickpember Apr 19 at 0:11
  • This morning when I came in to work the problem had reappeared--the screen background was black. I tried your suggestion: I tried to change the background, but it remained black. When I then killed XQuartz, the new background appeared. It seems XQuartz is somehow taking over the background. – rickpember Apr 19 at 17:26
  • I use XQuartz without a problem. I mainly use an editor called nedit which starts XQuartz when I edit a file. I have no problem with Xquartz. Version 2.7.11 – jmh Apr 19 at 21:54
  • Wait, i just had your problem when i was running XQuartz, – jmh Apr 19 at 22:01
1

Get your XQuartz showing in the menu bar. Click on XQuartz menu item and select Preferences. When the preference pane appears, click on the Output tab. One of the options is the Full-screen mode. Make sure the box is NOT checked. See the images below.

enter image description here

enter image description here

enter image description here

  • Thanks. The box was already unchecked for me – rickpember Apr 23 at 18:34

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .