Prior to Mojave 10.14.4, macOS would automatically attempt to mount locked Core Storage volumes, and if the necessary password was found in the current user's keychain this would occur automatically.

I've taken advantage of this behaviour until now to allow me to have multiple encrypted volumes that are all mounted automatically by successfully logging in to a user account on my encrypted startup volume.

However, macOS no longer appears to be attempting to mount Core Storage volumes automatically, despite the necessary passwords being in either my user keychain, or the system keychain, forcing me to mount them manually with Disk Utility. This isn't ideal as it ties the volumes to the user account, meaning if I log out the volumes are locked again.

This behaviour differs from encrypted APFS volumes, which mount automatically exactly as before. I know Apple is pushing us to move to APFS, but with still no conversion for AppleRAID (I'm not keen to erase and restore a multiple terabyte volume just to switch), and no use for Time Machine which still doesn't support an APFS backup volume.

Is there a way to restore or securely emulate the previous behaviour such that the volumes are unlocked automatically for all users?

In case the specifics of my setup are useful; my startup volume is an APFS encrypted volume that only my admin account is authorised to unlock, but I use other, standard, user accounts (one for work, one for general use etc.) when actually using my system. I then have an AppleRAID volume of several disks using Core Storage encryption, and a CS encrypted Time Machine disk.

  • Does How to Mount a Mac Drive to a Schedule help? This approach uses the command diskutil mount <Volume ID> Apr 16, 2019 at 12:18
  • @GrahamMiln in theory I could do something like this, but I'm unsure how to replicate the use of my system or admin keychain in order to do it; currently if I wanted to do this I'd have to store the password of the volume in plaintext as part of the command which I'm not sure is a good idea.
    – Haravikk
    Apr 17, 2019 at 8:33
  • Please see my updated answer. Steps 4–7 should solve your problem concerning @GrahamMiln's comment.
    – n1000
    Apr 25, 2019 at 8:54

2 Answers 2


It appears to be a bug that was introduced in macOS 10.14.4. In this discussion some users report that the problem went away by itself, a recent poster found the problem was solved in the latest 10.14.5 beta, and others have resorted to using the third-party app AutoMounter.

In my case, I have a SD drive permanently inserted into the SD card reader. That worked perfectly for years. Since the update it would auto-mount only about 50% of all reboots.

Therefore, it seems your best bet will be to wait for macOS 10.14.5 and report the issue to Apple. Another thing that you could try is to delete and re-enter the passphrase in your Keychain Access.app. Concerning your comment, the necessary steps would be:

  1. Open Keychain Access.app
  2. Find the key by entering the volume's name in the search field
  3. Select & delete the key
  4. Open Disk Utility.app
  5. Mount the volume in question and check the "Save passphrase" box
  6. Go back to Keychain Access.app and locate the volume key again
  7. Drag & drop they volume key into the "System" category in the left sidebar of Keychain Access.app. This step is necessary to enable auto-mounting.

P.S.: I experience another issue, which I suspect is related to this one. Possibly a new UUID is assigned to the drive which could be the reason it is not auto-mounted anymore.

  • Unfortunately re-adding the items in Keychain Access doesn't resolve the problem; it also doesn't seem to be the UUID issue, since the disks are Core Storage volumes the UUID being used is of the logical volume, not the physical disk.
    – Haravikk
    Apr 28, 2019 at 16:28
  • @Haravikk I am pretty sure by now that the real problem is a bug in macOS. These tips were meant as some things you could try. Don’t Core Storage volumes use UUIDs as well?
    – n1000
    Apr 28, 2019 at 16:33
  • Yeah, but they definitely haven't changed (you can compare which UUID the keychain is using by looking at the password entry for the volume). It does seem to be a definite bug, I was really hoping for a workaround to use in the meantime; Automounter is one, but that's a paid app, I was hoping for a way to use diskutil or similar to bypass the bug for now.
    – Haravikk
    Apr 29, 2019 at 10:49
  • @Haravikk Oh – thanks, I didn't know about the UUIDs in the Keychain. Another piece in the puzzle to solve my other issue. I really hope 10.14.5 is released soon...
    – n1000
    Apr 29, 2019 at 10:52

So Apple do indeed seem to have resolved this issue in macOS 10.14.5, it feels weird to answer this myself but there it is.

If you're having trouble with encrypted drives not mounting automatically, and are on macOS 10.14.4, then upgrade.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .