2

This is what happened: I upgraded my passwords on different services, including Microsoft's, which I only use it to work with OneNote. As expected, all apps with login changes asked me to re-login, no issues there.

Except with OneNote. I've been using OneNote in this MBP Sierra for a long time without any problem. It prompted me it couldn't sync with the cloud, understandably, and asked for the correct login info, so I did like I did with other apps. But here's what happens:

enter image description here

I enter my e-mail, click Next:

enter image description here

And that's all she wrote. I can't put in a password; it gets stuck there forever. I've tried reinstalling; reinstalling with a mac reboot in between; uninstall, update everything and install back... Always cleaning the plist's, cache's, etc. with CleanMyMac. No luck. It's the only office product I use. And it gets stuck whatever I write as the username.

I can log online fine. But OneNote in local is stuck.

I've talked to the "Office support team" on the chat, and then over the phone, to no avail. The phone assistant who was supposed to be the last resort could only tell me to sign out and in again, having missed that I'm not logged in. Well, they did give me a link to prior versions, same problem. So I'm thinking something's fishy with my mac.

I've observed weird behavior from the Console. At the beginning you could tell the thing was in a loop:

enter image description here

After reinstalling back the newest version again, I see this:

enter image description here

But then it goes back to the last capture with green arrows.

Reading "keychain" there made me think maybe OneNote has always stored the password there (I don't recall, honestly) and it has some meltdown because it's not a valid password anymore. So I opened the Keychain app and found one instance of "OneNote" with the password "M" (??). Weird. I deleted that entry... and it's still stuck the way you see it from the captures.

What can I do? Are there any caches or files I should do something with? It's still seemingly prompting the keychain...

1

I like to do a quick test by making a new user account on the Mac and log out of the user account with the problem, in to the new account and try launching and re-licensing the apps.

Outlook seems to pull the most reliable licenses, followed by Word / Excel / PowerPoint, but I don’t know you can’t start with OneNote - just that I typically use another app.

That being said - here is one official KB on fixing keychain permissions and three super helpful / open-source scripts to help with removing licensing entries so you can get a fresh launch. FWIW - reinstalling almost never fixes a license or keychain issue, but it does solve other issues from time to time, so good you ruled that out already.

I like to start with nuking the keychain first, then proper clean unlicensing and if all else fails, resetting the flight (Insider slow / fast / etc...). You might check what license you have before starting - it would be good to be clear if your’re a serialized volume license, O365 or other licensing scheme.

  • "reinstalling almost never fixes a license or keychain issue" I suspected, but it's good to know! – Carles Alcolea Apr 16 at 17:10
0

I kept digging, checked all MS forums until I found a post where turns out today another mac fellow was having the same problem so I joined in on the topic.

In case more people end up here with the same issue, for me, typing (pasting, actually) the password on the loading screen got me through. If that doesn't work check that post.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .