0

I have a 3rd generation AppleTV and am trying to configure it with AppleConfigurator2. My version of AppleConfigurator2 (2.7.1) is unable to detect the device. What version of AppleConfigurator2 is able to manage a third generation AppleTV?

1

I found this page with the following bullet list on it, titled: Apple Configurator 2 makes iPad and iPhone deploys even easier for SMBs.

Requirements for running Configurator 2.0

System requirements
  • OS X El Capitan (10.11+) or later
  • iTunes 12.3 or later
Device requirements
  • Apple TV (2nd Generation or later)
  • iPhone
  • iPad
  • iPod Touch
iOS requirements
  • iOS 7 or later

The disconcerting part with much of what you'll find about 2nd and 3rd Gen AppleTV devices is that the official pages maintained by Apple all seem to redirect you now to a GiveBack page to trade in your device.

NOTE: One of the more useful pages was the actual Mac store landing page for AppleConfigurator2. On that page is a "Version History" link which details the various releases.

If you look in the Apple forums and search for 3rd Gen AppleTV you'll find others who have this version of the device and are struggling to get it to work as well.

For example - Purchasing used appletv

The 3rd gen has long been discontinued, and hasn't received an update since 2016. It doesn't run apps, just preset content sent via server, and providers have started to drop support. You also wouldn't have access to things like iCloud Photo library, Apple Music, and airplay 2.

I would suggest to go for the 4th gen (now rebranded as Apple TV HD)

My advice would be to use this device for what it is, but if you want to do anything more with it, it's probably time to upgrade to a newer device.

References

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .