8

I'm trying to plug an external screen on my 2010 macbook pro 15", but when I set the maximal resolution, 1920*1080, the image seems a little constrained, and a big black vertical bar appear on the external screen. Here is a picture of it.

enter image description here

When I move my cursor from my macbook to the screen, the cursor goes straight from the edge of the MBP to the visible part of my wallpaper on the external screen.

When I set up a lower resolution, the problem goes away, but the display is then a little blur, because it's not the native resolution of the external screen.

Does anyone have any idea what I can do to have a good display ?

Thanks.

Edit

  • I tried various frequencies with no success.
  • I followed this post that seems really close to my problem: Mini DisplayPort to VGA adapter and Widescreen (FullHD) Monitor with no success. Deleting this /Library/Preferences/com.apple.windowserver.plist didn't fix the display.
  • This bug only appear with my MBP. Other colleague with same generation MBP have no problem to use this screen at 1920*1080. But I get this problem only with this screen and no other.
  • I tried to use another VGA <-> MiniDisplay, same result. Tried to use a DVI <-> MiniDisplay port, same result.

I'm pretty stuck on this one. Do you think I might call Apple?

  • Are you using the right frequency? have you tried "resetting" your display settings to factory default or similar in the monitor? – Martin Marconcini Jan 5 '12 at 21:55
  • @MartínMarconcini Yes, with no success, see my edit. – Clement Herreman Jan 6 '12 at 10:39
  • I see you've tried everything. You haven't mention one thing. Can your colleague's MBP using the same cable/adapter/screen work without problem? You say he had no problem using the SCREEN, but don't mention if he was using the same adapter. If he was, then you will need to take your machine to an App store to see how that adapter reacts there. ALso try creating a blank new user and see if under the new user things work. – Martin Marconcini Jan 6 '12 at 13:08
  • With switching cable and adapter, my colleagues have no problems. Thanks to @ioi I fixed this. – Clement Herreman Jan 8 '12 at 17:42
5

Try this:

• Go into Displays Preferences > Check Mark the box for "Show displays in menu bar"

• Under the resulting icon in the menu bar, drop the menu and set "Number of recent items" to 10.

• Click the menu again and you should see a list of recently used timings/formats. Multiple 1920 x 1080 might appear, switch to one or the other and it might just fix your issue.

Also:

In Displays Preferences > Displays > “Options” tab/button near the top of the window and make sure the “overscan” box is checked.

It would be helpful to know if you're trying to run 1080i or 1080p, and what model of your external display is.

  • Thank you, your recently used formats trick worked, even if I don't understand why... – Clement Herreman Jan 6 '12 at 13:17
  • @ClementHerreman, awesome! I'm glad it worked for you. Apparently it's a long-standing bug that's never been squashed. ;-) – l'L'l Jan 6 '12 at 14:09
  • Hm. I'm the famous colleague and I'm experiencing the same issue but with an other screen at home. None of these suggestions worked for me. Screen is a 27" Ilyama Prolite. – Zenklys Jan 6 '12 at 21:34
  • @Zenklys: Sad to hear that :/ – Clement Herreman Jan 8 '12 at 17:42
  • Finally, the issue was solved. Switched the VGA for DVI. Everything works great, out of the box. – Zenklys Jan 16 '12 at 9:54
5

My monitor shows exactly the same black sidebar on the left. Tried many tips and tricks. And finally unplug the miniDP to VGA connecter on both side and reconnect again solve the problem.

I tried to change the VGA side here and there for hours. :( so stupid me. So I guess some other also had the same experiences but I don't know why the answer is marked down to negative scores...

I didn't mean to solve all the problem for all. But just a mark for myself that shows it solved my problem and hopefully will help some of the others.

  • Thank you! I've been having this problem every few months for the last couple of years, so thanks for posting your fix: it worked immediately! – Charlie Harding Mar 26 '16 at 22:28
  • 1
    This is the first time I feels that I helped on stackexchange. It is important for me to know that. It encourage me to do more. – Kangqiao Zhao Mar 27 '16 at 13:54
  • I still had issues with the VGA cable. In my case, I was able to use a HDMI cable which solved the problem. If I was less lazy, I'd try a different VGA cable, but the HDMI has solved the issue for now. – thirdender Jul 16 '17 at 3:31
2

Find out what the native resolution of the external monitor is and configure the Mac to output that exact resolution (and 60Hz refresh).

If you're using an analogue signal (VGA, often a blue plug), push the auto adjustment button on the external monitor afterwards.

If that doesn't fix it, reset the monitor's settings (in the on-screen menu of the monitor) to the default.

Edit: Still not fixed? Swap out the monitor cable and the Mac's mini-displayport adapter.

Edit 2: Also, get a new wallet.

  • 1
    Hey, you don't like my wallet ? #sadpanda. Unfortunately, your solution didn't seem to work. Thank you anyway =) – Clement Herreman Jan 6 '12 at 13:20
1

if you have the remote for the monitor, go in the menu and select "auto Image"

  • It sounds like you're saying that @ClementHerreman needs to use the menu on the monitor to run automatic configuration. I suggest you make your answer more clear. – Jake3231 Feb 26 '18 at 23:21
  • How could it be more clear? This was the solution that worked for me. – Chris Conover Aug 21 '18 at 4:47
0

Simply changing the VGA cable fixed this problem for me.

  • It's weird that someone would downvote a solution that worked for someone else. If it worked, and he offers it, it can only be a good thing, even if it doesn't work for everyone. – Chris Conover Aug 21 '18 at 4:46
0

Had the same issue with my 2012 iMac... Took the VGA-to-MiniDP cable out of the one tunderbolt port and put it in the other one and it works fine now.

0

I tried all the above suggestions, but it didn't work for me. But now, I solved it! After many, many days of frustration and hours wasted. I did a reset on the PRAM and it worked like a charm. The instructions are here http://www.macworld.com/article/2881177/how-to-reset-your-macs-nvram-pram-and-smc.html

  • 1
    Welcome to Ask Different! Whilst this may theoretically answer the question, it would be preferable to include the essential parts of the answer here, and provide the link for reference. – Jaime Santa Cruz Jul 20 '15 at 17:37
0

I had the same black bar on my older view sonic lcd display. It would not display 1920x1080 without the black bar. When I opened "displays" under the system settings, I held down the ALT/OPTION key and it changed the "gather windows" button to "detect displays." When I clicked on that, it fixed the problem with the default for display option selected. Hope this helps someone!

0

I had the exact situation you described. But for me, shutting my powerbook down seemed to work. Perhaps there was some strange setting happened from all the sleep/awaken cycles.

Don't forget the easy solutions!

  • It seems that the problem is intermittent. So this answer doesn't really solve anything; I was just seeing the problem some times. I'm guessing there's something wonky with the video card. Sigh. – Scott Biggs Jul 31 at 4:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .