3

I recently upgraded my mid 2011 Mac mini to macOS High Sierra. I purchased the Magic Mouse 2 about a year ago, but really loathe the charging port on the bottom (unbelievably stupid design, but I digress). As such, I kept my old (original) Magic Mouse handy for when I needed to charge the Magic Mouse 2. I never had problems with this use case in OS X El Capitan.

However, today when I tried to use the old Magic Mouse, macOS absolutely freaked out and neither of the Bluetooth mice could connect. I had to use a generic Logitech USB mouse to "forget" both of them (old and new), then I could reconnect the Magic Mouse 2 after it charged.

So my question: is the original Magic Mouse unsupported in macOS High Sierra? (edit: it definitely is supported, not the issue). Or perhaps I simply can no longer use the Magic Mouse and Magic Mouse 2 interchangeably?

Update 1: Forgetting and re-pairing both of the the mice was a temporary fix. Nothing else worked, including rebooting.

Update 2: Issue has returned. I again had to fight macOS tooth-and-nail to get the Magic Mouse 2 paired after using the Magic Mouse!

Update 3: One thing I forgot to mention: when the Magic Mouse 2 has lost pairing (after using the Magic Mouse) and I plug it in and switch it on, the "Mouse" section of System Preferences goes absolutely berserk, rapidly alternating between the normal screen and the "looking for bluetooth mouse" screen.

  • 1
    After your Re-pairing, when does this happen? Does it only occur after an update? Or when they are both on and/or trying to/or have connected? Do you have more than just your mice connected via bluetooth? – JayRizzo Jun 24 at 22:35
  • 1
    Do either of your mice have "Drifting" issues? Where, the cursor moves when you are not? – JayRizzo Jun 24 at 22:37
  • Neither seem to have any drifting issues. – KidACrimson Jun 25 at 0:20
  • The issue occurs after I stop using the MM1 and try to switch back to the MM2 - the Mac Mini "fights" me on this. It easily allows me to switch from the MM2 to the MM1, however. – KidACrimson Jun 25 at 0:21
  • 1
    Are you leaving both of the mice on when you switch? If so, try turning off the MM1 and then Switching over to MM2. Lastly, does this ever cause issues when you are using just one mouse? – JayRizzo Jun 25 at 0:24
1
+50

1st Answer Alt. Using The Interface Answer (Credit user3439894)

(Short Way)

Does the command line version from my understanding.

  • Open System preferences
  • Open Bluetooth Settings
  • Click on Advanced
  • Uncheck the 2nd Box "Open Bluetooth Setup Assistant at startup if no mouse or trackpad is detected" Advanced Bluetooth Settings

Note: this may look different on your Mac as I am running on MBP macOS 10.14.5 Mojave

 

Fun Note: To open Bluetooth Preferences directly from Terminal run: open /System/Library/PreferencePanes/Bluetooth.prefPane

1st Answer Using Terminal/Commandline

My hypothesis, is I believe the bluetooth devices may be fighting.

If you don't mind a little terminal action, then, lets try turning off the Automatic Search for bluetooth.

Open Terminal and run: Update 2:This is not a mandatory step this will show up if you run After the write steps.

defaults find 'AutoSeek'

This for me just returned:

Found 1 keys in domain 'com.apple.systempreferences': {
    BluetoothAutoSeekPointingDevice = 1;
}

So, I ran:

defaults read com.apple.systempreferences BluetoothAutoSeekPointingDevice

This should return 1, as it does on my machine. So, let's turn this off.

defaults write com.apple.systempreferences BluetoothAutoSeekPointingDevice -bool false

Doing some more research, I also found something similar, in other plist files.

defaults read /Library/Preferences/com.apple.Bluetooth BluetoothAutoSeekPointingDevice

But to change this is requires your admin password as it is part of the SIP protection.

sudo defaults write /Library/Preferences/com.apple.Bluetooth BluetoothAutoSeekPointingDevice -bool false

Then, to make the changes take effect: (Thanks to user3439894 for the update from the comments.)

killall cfprefsd

Note: You may not have com.apple.systempreferences the alternative is com.apple.systempref.plist So if you run the defaults read and get an error please try the substitute.

3rd Answer

Try using blueutil and let me know.

4th Answer

Try "Reseting the System Management Controller (SMC) on your Mac."

  • 1
    Thats ok, that just means that there has not been a set value "Set". I have been going thru the PLIST files and alot of the not obvious "Options" are not set in the plist files until you run a defaults write call on the terminal. – JayRizzo Jun 25 at 0:10
  • 1
    Ok cool - I do have a com.apple.systempref.plist file... – KidACrimson Jun 25 at 0:11
  • 1
    I updated my answer to showcase that the defaults find is optional. I hope that works for you. As I am not sure if the mice are fighting over the bluetooth. – JayRizzo Jun 25 at 0:13
  • 1
    The value for BluetoothAutoSeekPointingDevice is a boolean not an integer. - "-bool[ean] Allows the user to specify a boolean as the value for the given preference key. Value must be TRUE, FALSE, YES, or NO." - You also can just uncheck [] Open Bluetooth Setup Assistant at startup if no mouse or trackpad is detected In System Preferences > Bluetooth > Advanced instead of using defaults. See: imgur.com/a/nYTNanI – user3439894 Jun 25 at 0:50
  • 1
    Thanks for the updates @user343894 I kind of figured as much but the problem was when you do defaults read you actually end up getting back only the integer value so I was working on the idea is that they were interchangeable. – JayRizzo Jun 25 at 1:09
1

I cannot find any Apple documentation stating that the original Magic Mouse is unsupported in newer OS versions.

Your problem is more likely to be just one of Bluetooth connectivity. Apple provides a troubleshooting document that describes the Magic Mouse and Magic Mouse 2 together. Other remedies for problems can be found here.

The Magic Mouse is not one of Apple's strongest designs, and you may prefer a third-party mouse, or the Magic Trackpad, which I find much better. (You can leave it plugged in while using it, for starters!)

  • Thanks, Ben. I've seen the that Apple troubleshooting doc, but it's useless in my situation, unfortunately. I've tried all the obvious things multiple times. Despite the bottom charging-port, I actually strongly prefer the Magic Mouse over any other mouse or trackpad, (I would even use it on my Windows machines if I could) which is why this is so frustrating to me. – KidACrimson Jun 18 at 14:39
  • I can't use two Bluetooth mice of any kind simultaneously. – Wowfunhappy Jun 23 at 2:03
  • @Wowfunhappy That sounds like a different problem, so you should start your own question. However, I'd say having two Bluetooth mice at the same time is likely to cause problems. Do you really use two mice at the same time? – benwiggy Jun 23 at 10:27
  • @benwiggy Not a question, I'm agreeing with you—there just isn't enough bluetooth bandwidth for two mice, I think that's what OP is describing. – Wowfunhappy Jun 23 at 10:56
  • 1
    @Wowfunhappy, RE: "there just isn't enough bluetooth bandwidth for two mice", I have a Magic Mouse, Magic Trackpad and a Magic Keyboard all using Bluetooth and connected at the same time to a MacBook Pro in Clamshell Mode, and have no issues, so I don't necessarily agree with the statement "there just isn't enough bluetooth bandwidth for two mice". – user3439894 Jun 24 at 23:14
0

Well, it seems to support. I can't find any apple documents that says no. At the same time, i have both apple mouses, and it works with high serria. Hope this helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .