0

I have an external drive with two partitions, the first of which I use for Time Machine backups. The other day I got a message telling me that my drive had been unplugged without being ejected first (not true). Today when I plugged it in, the Time Machine partition did not mount but the second partition did.

When I try mounting the partition in Terminal I get: Volume on disk2s2 timed out waiting to mount

I tried $ diskutil repairDisk disk2 and got:

Started partition map repair on disk2 Checking prerequisites Checking the partition list Adjusting partition map to fit whole disk as required Checking for an EFI system partition Checking the EFI system partition's size Checking the EFI system partition's file system Checking the EFI system partition's folder content Problems were encountered during repair of the partition map Error: -69854: A disk with a mount point is required

I tried $ diskutil repairVolume disk2s2 and got:

Started file system repair on disk2s2 Backup Repairing file system Volume is already unmounted Performing fsck_hfs -fy -x /dev/rdisk2s2 File system check exit code is 8 Restoring the original state found as unmounted Error: -69845: File system verify or repair failed Underlying error: 8: Exec format error

I did $ ps aux | grep fsck and got:

root 642 22.8 12.6 6396120 2107688 ?? U 3:27PM 15:48.20 /System/Library/Filesystems/hfs.fs/Contents/Resources/./fsck_hfs -y /dev/disk2s2

According to another thread here, this means that fsck has "hijacked" the partition, but I don't know what that means.

I don't know what to do at this point. My big concern is not losing my Time Machine backups.

  • Have you tried trying to repair the drive with fsck in single-user mode? This page has some tips about this method, and also about attempting to repair in the Safe and Recovery boot modes. – IconDaemon Apr 12 at 20:51
  • All those instructions seem to be for repairing a boot drive, not an external drive. It's not clear to me how or if they can be modified to repair an external drive. – dhnyny Apr 12 at 21:05
1

Okay, I figured out what was going on: When macOS detects a drive being unplugged without being ejected (which I don't think happened but I did get a message saying it had), the next time you plug the drive in fsck is going to go to work automatically, to check out the drive and attempt to repair it if need be. Unless you go looking, you'll get no indication that this is what's happening other than that the drive (or a partition on it) won't mount. This super helpful comment was key to my understanding what's going on: https://superuser.com/a/1013435/955941. After about 10 hours, fsck finished and the partition mounted correctly.

  • Excellent find. The fsck is hidden very well, so unless you know to check for it in Activity Monitor (show all processes) or ps or top you might never get a visual indicator that the system has paused the mount and might be checking for days or weeks. apple.stackexchange.com/questions/348635/… – bmike Apr 14 at 15:56

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .