0

On my iPad (iOS 12.2), I'm trying to update my existing apps. The app store requests that I authenticate with my Apple ID password. It then brings me to my payment information screen, where it asks me to configure my payment method.

I select "None" on the payment method screen, since I'm only planning on updating apps and installing free ones on this iPad for now. After clicking "Done", it pops up the Apple ID authentication box again, which brings me back to the payment method screen, and this loop continues forever. I can't update my apps or install any new apps, even free ones.

In my App Store settings, I have disabled the "Require Password for Free Downloads" setting, but it doesn't make a difference. I can't install or update free apps.

  • Try logging out of iCloud and other Apple ID-related services and try again. – IconDaemon Apr 12 at 13:56
  • Thanks. Unfortunately that didn't work for me, though I've read that it worked for some others. I posted the answer that worked for me in case it helps someone with the same issue as me – Chris.B Apr 12 at 15:13
1

In the past, I had set my payment method to be a pre-paid Visa gift card, which I used to download several paid apps. That card no longer has a balance at this point. This seems to be what was causing my problem.

I was able to fix this in the Payment Method screen by adding a new credit card (I used my real one) and hitting "Done". At this point my apps started updating and I wasn't prompted to enter my Apple ID password again.

After I entered the valid credit card information, I went back in to the Payment Method screen and set it back to "None", which worked. I can now install and update free apps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .