7

I am on 10.14.4, the same thing was happening at least on 10.14.1.

Laptop: MacBook Pro (Retina, 15-inch, Mid 2014)

So the problem is if I open  "Apple Menu" in top left corner and click any of the following options:

  • Shut Down...
  • Restart...
  • Log out My Name

nothing happens.

sudo reboot works fine, holding the power button works fine, but that's not a graceful shutdown and I would like to avoid it, it also prevents updates from being applied if shut down this way.

Also when I go to Preferences > Software Updates > click Update Now then a dialog pops up with an option "Restart Now". Clicking it does nothing similar to Apple Menu.

What I tried:

  • I checked the Console application for logs (nothing relevant in there)
  • I checked /var/log/system.log, I checked /var/log/shutdown_monitor.log (nothing relevant in there)
  • SMC reset
  • NVRAM reset
  • Created new fresh user, to see if it's a problem with my user account (the issue persists)
  • I disabled all the login items and bunch of startup services (java updates, and bunch of similar non-system stuff)
  • 1
    If the Mac is off and you turn it on while holding the SHIFT key (safe mode - startup takes LONGER) does restart/shutdown/logout work then? – Steve Chambers Apr 12 at 11:43
  • @SteveChambers no. It does not work. – ewooycom Apr 27 at 15:33
  • Have you tried reseting NVRAM too? Also, what model Mac is it? E.g., copied from  > About The Mac > Overview: MacBook Pro (Retina, 15-inch, Early 2013) – user3439894 May 15 at 14:38
  • @user3439894 Updated the question. Will have a look into reseting nvram later Today. – ewooycom May 15 at 15:26
  • 2
    Not confident it will help but it's one of the things on the standard check list. Have a look at Reset NVRAM or PRAM on your Mac IMO The fact that the issue persists in safe mode is not good and may warrant more drastic steps, i.e., reinstall the OS or a clean install of the OS. Have a look at: How to reinstall macOS from macOS Recovery NOTE: Make sure you are properly backed up before installing/reinstalling macOS! – user3439894 May 15 at 15:40
1

This looks suspiciously like a problem with permissions. Open /Applications/Utilities/Disk Utility and fix permissions on your drive then reboot and see if it works.

EDIT: After comment, repair permissions is not available anymore in newer macos releases.

Then you will have to reinstall macos, I am afraid.

  • 2
    The OP is running macOS Mojave and its Disk Utility does not have the Verify Disk Permissions and Repair Disk Permissions commands. They have not been available in Disk Utility since OS X El Capitan. From Repair disk permissions with Disk Utility, "Beginning with OS X El Capitan, system file permissions are automatically protected. It's no longer necessary to verify or repair permissions with Disk Utility." – user3439894 May 17 at 13:14
  • 1
    Thanks, I am travelling and have no access to a Mac right now ... – user2531336 May 17 at 18:35
-1

Try a NVRAM reset as others have pointed out. If that doesn't do it you almost definitely need a reinstall of OS X.

Restart your mac and hold cmd + R until you see the Apple logo and use ‘Install OS X ___’. This could take a few hours but none of your files/accounts will be erased - it just replaces the System folder which is where all the mechanics for that stuff is at.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .