1

Under macOS 10.14.4, I've enabled the following dictionaries:

Yet, when I hid ⌃⌘D, I get the results as follows:

I would expect the results to show only American English dictionaries, and not British English.

  • I'm happy with British English :) – Solar Mike Apr 11 at 15:55
2

This seems to be a bug that appears when you're switching languages. I know I had switched from British to American English at some point before.

What you have to do is:

  • Open Dictionary.app
  • Go to Preferences
  • Uncheck all dictionaries
  • Enable the ones that you need

Now the order is correct, and the British dictionary entries are gone from the results.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .