1

I've setup my email account with Mail.app. However, I cannot send mail.

The reason for this is that whenever I try to send mail, Mail.app always selects a legacy SMTP server, which I used to have configured, instead of whichever one it selects.

It gets to the point where if the dialogue for selecting an SMTP server comes up, and I select a different one, it'll still use the legacy one. When I click "Edit SMTP server list" I can change the list, however, the very next time I open that list, all my changes are discarded, and the legacy server is back.

How do I nuke Mail.app?

1

You could check if macos is trying to manage your connection settings automatically. That is controlled from inside the preferences for the Mail.app, under Accounts, and under Server Connections, at the bottom of the page. If the checkbox "Automatically manage connection settings" is checked, then macos will try to manage these settings for you. There's more information about what it does and how to disable it here: https://support.apple.com/en-us/HT204208

If that does not help, you could also remove that account completely. However this is a more drastic operation. In System Preferences (not in the Mail.app), there is a preference pane for Internet Accounts. Try removing your email account and then readding it. There's a tutorial here that explains how: http://osxdaily.com/2016/04/04/delete-email-account-from-mac/

  • I've actually removed and added the account in question several times, and it doesn't work. Even stranger, even after deleting the account, Mail.app somehow remembers the offending SMTP server. – wen Apr 11 at 17:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .