6

I have a "Microsoft Sculpt Ergonomic" keyboard, connected with USB to my Mac 13" (from 2018). The keyboard input starts to lag at some random times. I have been using the keyboard on my older Mac 15" (from 2015) for more than a year and never had a problem. Both Macs are with the same OSX version (Mojave 10.14.4).

I thought the problem is in the batteries (it uses 2xAAA batteries). Changed them with brand new ones. Issue persists.

I tried connecting a Magic Apple keyboard and at moments when the Microsoft keyboard lags, the Apple one does not.

Most often the problem happens within the browser, but continues persisting in Slack, IDEs and other apps. It is strange, thought, that the lag occurrences are not connected to higher load on the CPU or memory.

2
  • 2
    I've seen some weird issues depending on where I have the USB receiver. When I tried using the USB hub in my display (receiver ends up behind the screen), I had a spotty connection. Ended up getting a little USB extension cable so the dongle hangs below the display, and cleared things up. – ernie Apr 10 '19 at 17:12
  • Yeah, I know about this issue, since I had the same at first. But the dongle is in a direct line of sight to the keyboard, so the signal shouldn't be disrupted. That's why I was weirded out... – Milkncookiez Apr 11 '19 at 7:12
1

The lagging sounds like wireless interference to me.

Many devices can be the culprit; wireless routers, displays, other Bluetooth and WiFi enabled devices, and even devices attached via USB 3.0 cables with poor shielding.

The closer you can get your USB dongle to the keyboard, and the further it can be from sources of interference, the better. A good USB extension cable might be what you need to take care of this issue.

1
  • 1
    Damn... okay. I will try. It's just weird because I had no problems with the older Mac. And the new laptop is at the same place/distance from the keyboard as the old one was. I'll try to keep it a bit closer and see how it goes :) – Milkncookiez Apr 12 '19 at 7:41
1

I had the same issues:

  • Severe lag for keyboard/mouse
  • Eventual complete disconnections

Apparently I fixed it by disabling handoff.

I read it somewhere but I cannot find it.

2
  • Thanks for taking the time to write an answer! Just some feedback to help make it better...it’s important to summarize the key parts of the linked document here because links often go stale making the answer useless. – Allan Feb 19 '20 at 13:43
  • This didn't work for me - still getting random key lag and mouse lag w/ microsoft sculpt (the best keyboard ever). Re-mapping keys is no issue. Still up-voting this because the link to disable the handoff feature was much appreciated. – Justin Standard Apr 8 '20 at 20:50
1

I think it might be wireless interference. I have a pair of bluetooth headphones and the lag only seems to happen with the headphones are connected to the computer. I've had this keyboard and mouse combo for a couple of years and think the two are highly related.

I'm not sure how to resolve the issue though, but I will investigate some more and hope to provide updates in the future.

-1

I started having issue this morning, mine was resolved by setting Key Repeat to off in keyboard setting.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .