0

I have disabled the Wi-Fi by moving the IO80211Family.kext from /System/Library/Extensions with SIP disabled of course. However, this does not seem to work anymore. Before (on macOS High Sierra and below) the Wi-Fi icon showed a cross after rebooting, but not anymore on macOS Mojave. Any suggestion why this does not work anymore? Or alternatives for disabling Wi-Fi?

Related issue:

The hardware is a Late 2018 Mac mini.

  • Did it stop working after updating without you doing anything? Because I'd assume you would have to move the file after every major update (just a guess though). What about the second suggestion in that answer you linked to? Why do you need this by the way? I was thinking there could be parental control solutions too... – Joonas Apr 10 at 12:18
  • Is it just the icon which doesn't change, or is WiFi really not disabled? – nohillside Apr 10 at 13:50
  • @Joonas I moved the file. Also IO80211FamilyV2.kext. @nohillside WiFi is really not disabled, since it actually lists all current hotspots/SSIDs. – tr4px Apr 10 at 14:02
  • Can you list what else you have under that directory? - ls /System/Library/Extensions/ |grep IO802? – slm Apr 11 at 1:21
  • It suddenly was disabled. But I can't explain why. Maybe it need two reboots. – tr4px Apr 16 at 8:27

You must log in to answer this question.

Browse other questions tagged .