0

I am building PyTorch with GPU support from source on my MacBook Pro.

As CUDA related stuff being required, I have to install NVIDIA Web Driver instead of using the OS X Default Driver. However, the screen blinks every several minutes and the system even crash every so often(maybe less than an hour, maybe more)after switching to NVIDIA Web Driver. How can the problem be solved?

The crash looks like:

enter image description here

The crash report is as follows:

something omitted...
*** Panic Report ***
panic(cpu 2 caller 0xffffff7f8eb32705): "GPU Panic: mux-regs 2 0 20 0 0 8 severity 3 switch-state 0 IG FBs 1 EG FBs 0:0 power-state 6 3D idle HDA idle : \n"@/Library/Caches/com.apple.xbs/Sources/AppleGraphicsControl/AppleGraphicsControl-3.14.50/src/AppleMuxControl/kext/GPUPanic.cpp:149
Backtrace (CPU 2), Frame : Return Address
0xffffff80201fb1e0 : 0xffffff800b4e756c 
0xffffff80201fb260 : 0xffffff7f8eb32705 
a lot of similar lines omitted...

      Kernel Extensions in backtrace:(I removed some details)
         com.apple.iokit.IOAcceleratorFamily2(311.16.2)
            dependency: com.apple.iokit.IOPCIFamily(2.9)
            dependency: com.apple.iokit.IOGraphicsFamily(515.4)
         com.apple.driver.AppleMuxControl(3.14.50)
            dependency: com.apple.driver.AppleGraphicsControl(3.14.50)
            dependency: com.apple.iokit.IOACPIFamily(1.4)
            dependency: com.apple.iokit.IOPCIFamily(2.9)
            dependency: com.apple.iokit.IOGraphicsFamily(515.4)
            dependency: com.apple.driver.AppleBacklightExpert(1.1.0)
         com.nvidia.web.NVDAResmanWeb(10.1.8)
            dependency: com.apple.iokit.IOPCIFamily(2.9)
            dependency: com.apple.iokit.IONDRVSupport(516.1)
            dependency: com.apple.iokit.IOGraphicsFamily(515.4)
            dependency: com.apple.AppleGraphicsDeviceControl(3.14.50)
         com.nvidia.web.NVDAGK100HalWeb(10.1.8)
            dependency: com.nvidia.web.NVDAResmanWeb(10.1.8)
            dependency: com.apple.iokit.IOPCIFamily(2.9)
         com.nvidia.web.GeForceWeb(10.1.8)
            dependency: com.apple.iokit.IOPCIFamily(2.9)
            dependency: com.apple.iokit.IONDRVSupport(516.1)
            dependency: com.nvidia.web.NVDAResmanWeb(10.1.8)
            dependency: com.apple.iokit.IOGraphicsFamily(515.4)
            dependency: com.apple.iokit.IOAcceleratorFamily2(311.16.2)
BSD process name corresponding to current thread: kernel_task

loaded kexts:
some lines omitted...
com.nvidia.CUDA 1.1.0
com.nvidia.web.GeForceWeb   10.1.8
com.nvidia.web.NVDAGK100HalWeb  10.1.8
com.nvidia.web.NVDAResmanWeb    10.1.8
com.nvidia.NVDAStartupWeb   10.1.8
com.apple.driver.AppleGraphicsDevicePolicy  3.14.50
com.apple.driver.AppleHDAHardwareConfigDriver   279.48
com.apple.driver.AppleUpstreamUserClient    3.6.4
com.apple.driver.AppleIntelHD5000Graphics   10.2.5
com.apple.nvidia.NVDAStartup    10.1.7
com.apple.driver.AppleGraphicsControl   3.14.50
com.apple.AppleGraphicsDeviceControl    3.14.50
com.apple.iokit.IOGraphicsFamily    515.4

some lines omitted...

My environment:

  • MacBook Pro (Retina, 15-inch, Late 2013)
  • Kernel version: Darwin Kernel Version 16.7.0: Wed Oct 10 20:06:00 PDT 2018; root:xnu-3789.73.24~1/RELEASE_X86_64
  • macOS Sierra 10.12.6 (16G1618)
  • NVIDIA GeForce GT 750M
  • GPU Driver Version: 378.05.05.25f11
  • CUDA Driver Version: 387.178
  • Cuda compilation tools, release 8.0, V8.0.61

You must log in to answer this question.

Browse other questions tagged .