1

So I tried updating Xcode but after the update I still got the same version of it (so there was an update still available).

I decided to uninstall it by throwing the app in the trash. The update still remains. After clicking 'Update', nothing happens and now I can't use it.

Any help on this as it is very important for me right now?

Note: I deleted the Library/Developer folder too

5
  • 1
    Have you tried downloading it directly from Apple's Developer site? I thought you could still do that (in addition to the MAS).
    – fsb
    Apr 9, 2019 at 12:57
  • @fsb It prompts me to iTunes which in turn opens the link in the AppStore of my mac.
    – user8911
    Apr 9, 2019 at 13:08
  • Try developer.apple.com/download You should be able to download a stand-alone version of Xcode.
    – Ɱark Ƭ
    Apr 9, 2019 at 16:26
  • @ⱮarkƬ I thought so too but the 'download' button gets me to iTunes
    – user8911
    Apr 10, 2019 at 0:10
  • Yeah, I had the wrong URL. Sorry about that. See the answer I just added.
    – Ɱark Ƭ
    Apr 10, 2019 at 13:47

1 Answer 1

1

There is a downloads page with all past versions of all of the developer tools on it, try https://developer.apple.com/download/more/

  1. Click on the "+" button to the left of "Xcode 10.2"
  2. Click on the "Xcode 10.2.xip" link to download Xcode.

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .