1

I have a Parallels VM which I'm using to test Internet Explorer and Edge. It's set to use a "shared network", and I can ping the host Mac (via ping 10.211.55.2). I've set up my hosts file as follows:

10.211.55.2 localmac

To test, I'm running python3 -m http.server on the host, which creates a web server bound to 0.0.0.0:8000. However, when I try to access this server from the Windows guest, by navigating to http://localmac:8000, I get a connection timed out error from Edge.

To reiterate, I am able to ping the host machine from the guest, and I can access the Internet from the guest. It's just HTTP from guest to host which seems to fail.

Is there a firewall setting or something which I have to configure to allow incoming connections? It seems like I'm doing everything correctly, according to the other StackExchange answers regarding accessing the host from a Parallels guest, but it doesn't seem to be working for me.

The host is MacOS Mojave (MacOS Version 10.14.4). I'm running Parallels Desktop 14, and the guest is a Windows 10 Enterprise Evaluation image (sourced from Microsoft's VM resources).

  • How do you have the network adapter configured for the guest? Host, bridged, NAT, etc? – Allan Apr 8 at 23:20
  • It's set to "shared network" in Parallels, which I'm guessing means NAT. I can see a new network adapter on the host, with the IP 10.211.55.2. The guest's network adapter has the IP 10.211.55.3. I can ping 10.211.55.2 from the guest, but I can't seem to make a HTTP connection. – quanticle Apr 9 at 3:56
  • Did you manually assign that IP to the host? Those IP conventions are what Parallels users for its network. You have to remember that shared networking creates a separate network and Parallels acts as a router. – Allan Apr 9 at 12:51
  • I did not assign the IPs manually. I'm using Parallel's DHCP to assign IPs. – quanticle Apr 9 at 13:15
  • Is the macOS firewall on? In that case, have you tried either disabling the firewall (System Preferences>Security & Privacy>Firewall) or adding port 8000 to the firewall (in System Preferences>Security & Privacy>Firewall, press the plus button and then select python3 - you may need to press Shift-Command-G to select the folder)? – jaume Apr 16 at 12:46

You must log in to answer this question.

Browse other questions tagged .