Since the recent macOS 10.14.4 update which includes Safari 12.1 (14607., last started to automatically submit web forms with login & password fields once a value for password or login is selected from auto-fill options. This seems to be related to the new 10.14.4 feature where Touch ID got an option to confirm auto-fill in Safari. However I have it switched off but Safari still does this crap. I'm curious if anyone else have the same problem and how to solve it.

UPD Starting Safari 13.0 (14608.1.49) auto-submitting is disabled!

  • 1
    I have this issue as well and I haven't figured out a way to disable the auto-submit of the forms. I like the security around touch-id but some AJAX and SPA apps don't behave well with this latest Safari update and can get into an infinite submit-reload due to touch-id.
    – voidmain
    Commented Apr 5, 2019 at 15:46

5 Answers 5


I have this issue too, and I've just spent a long time with an Apple Support chat agent.

This is a "feature" introduced in Safari 12.1.

What's new in the updates for macOS Mojave

Streamlines website login when filling credentials with Password AutoFill.

There is currently no way to turn this off. This is the solution the agent proposed. Submit a feedback to Apple:


...submit your feedback on the feature and your experience so far.

Maybe if we kick up enough of a fuss? It is a pain, and it also screws with captchas quite impressively...

  • i got the same problem. it gives problems when there is a captcha
    – Valerio
    Commented Apr 10, 2019 at 11:06
  • It is also happening on 10.13.6.
    – webjay
    Commented Apr 11, 2019 at 17:23
  • Correct webjay, this is for the Safari 12.1 update, not an OS update. I don’t know if Mac OS 10.12 will update Safari, to 12.1 but 10.13 and 10.14 both do.
    – ttt
    Commented Apr 11, 2019 at 21:08
  • 2
    I'm glad to say that this auto-submitting madness has stopped in Safari 13.0!
    – Ajax
    Commented Sep 24, 2019 at 19:08

I have seemingly found yet another sub-optimal workaround: disable Touch ID for autofill.

Confirmed to work on macOS Monterey and macOS Ventura.

  1. Go to System Preferences (System Settings in macOS Ventura 13.0 or newer) > Touch ID & Password
  2. Turn off Use Touch ID for auto-filling passwords
  3. Enter the system password in the pop-up.

⚠️ Note: turning this off also disables Touch ID authentication for choosing and filling passwords in Safari, meaning that all remembered passwords in KeyChain can be selected and auto-filled without verifying your fingerprint.


This seems to work for me.

<form id="myform" action="...">
    <a id="mysubmit">Submit form</a>

    window.onload = function() {
        document.getElementById('mysubmit').onclick = function() {
            return false;

It was an unnecessary feature built into Safari in my opinion!

  • 1
    WHere do you add this and what does it do?
    – mmmmmm
    Commented Sep 18, 2019 at 10:54

You can use StopTheMadness Safari extension to switch off auto submit behavior.


I got the same issue with Safari 12.1, but I think it's not so bad 1. For sites which require captcha, the form is working like before, does not auto submit 2. For other sites, I got issue when can not click 'Remember me', but at the end I just click to that option first, and fill username & password.

So, I am totally fine with this feature.

  • 2
    This is not an answer. It may be a comment.
    – ttt
    Commented Jun 9, 2019 at 7:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .