1

I tried upgrading my MacOS Bash from 3.2 to the latest version as in this article.

It involves installing the latest Bash with Homebrew and then setting the default shell with chsh. However, chsh doesn't appear to work with iTerm2 -- iTerm2 still is opening the old shell when I make a new tab. I see that there's an option in iTerm to to set the launch command, but I'm wondering if there isn't a better way... It is supposed to work across the board once its set as my login shell.

Can anyone tell me what I'm missing?

  • i followed the directions in the file you linked and it appears to have worked fine. If I start iterm and type bash --version i get version 5.03 returned. if i open a new window or a new tab they all are version 5 of bash. – jmh Apr 5 at 1:58
  • one thing i did differently, which shouldn't matter, is I did mot use Vim to edit the file as per the line:"sudo vim /etc/shells". I used a different editor but that shouldn't matter. – jmh Apr 5 at 2:07
  • But you did use sudo though? – Mark Apr 9 at 14:24

You must log in to answer this question.

Browse other questions tagged .