I'm trying to update Keynote in the Mac App Store and I get this message:

Unable to update “Keynote” To update this app, you need to accept it on the Account page in the App Store.

I get the same message for Pages and Numbers.

Where is the Account page?

enter image description here


While Simon's answer is correct, the reason this may be appearing for you is actually because you have those apps pre-installed. I ran into a similar situation just now. Despite already having those apps tied to my Apple ID, there's something about this having them pre-installed on my machine that breaks down.

Simply delete those apps. You'll be able to redownload and update them from that same "View My Account" page with no issues after that.

Tip: For those unable to reinstall (work computer, etc.) if you simply delete then "Move Back" from the trash you will achieve the same result.

  • How do you delete those apps? – Chris B. Apr 18 '19 at 14:15
  • 3
    Goto finder > Applications > 'here you can find the apps' > Right click and Move to Trash – wsha Apr 19 '19 at 17:53
  • This worked for me! Thanks! – Larry Freeman Jun 20 '19 at 23:02
  • For those not seeing the "Accept" button, this is the right solution. Delete those apps and then reinstall. Likely due to pre-installed apps on new Mac. – openwonk Jul 16 '19 at 3:23
  • Exactly! I had the apps preinstalled because I upgraded/migrated my account from a legacy MacBook Pro to a newer one (Touchbar, etc.) via OS X's Migration Assistant. Thanks @oversteps – A-Dubb Aug 12 '19 at 16:13

I found it under Store > View My Account.

Then click Accept.

Apparently this occurs when you have a new Mac that has certain apps (like Keynote) pre-installed, but you have also purchased them at some point in the past. So you are "adopting" the pre-installed ones into your Apple account.

App Store screenshot

  • 9
    I did what you said to do. Yet I couldn’t get the “accept” bar to pop up like you did. I did word for word what you said but it doesn’t show me where I can accept it and I have been trying to update iMovie. – Lewis Gibbs Apr 12 '19 at 4:59
  • Sorry to hear that. Maybe try rebooting? Another possibility is that there's probably a limit on how many Macs you can have the apps installed on. – Simon Woodside Apr 15 '19 at 3:34
  • 1
    For me,rebooting doesn't help, and I only have a single Mac. There is no "Account" page. – Chris B. Apr 18 '19 at 14:13
  • Awesome!! It works for me. Thank a lot – SRENG Khorn Apr 23 '19 at 5:07
  • This indeed is how you access your Account page, but as some others are pointing out the "accept" bar still doesn't show up when you have this issue because you transferred your data from an old Mac to a new one. See apple.stackexchange.com/a/356780/136577 for how to solve that. – Jacob Ford Jul 8 '19 at 18:15

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .