My Boot Camp assistant seems to be having problems (first I get not enough space, 40 GB, etc.) which I fixed by making a partition using Disk Utility, but then I didn't get an option that others seem to get to Create a usb bootable drive for windows 7 or later. It right away asked for the ISO and started downloading Windows support software, took forever, and then said there wasn't enough space on the partition (there was).

Without Boot Camp, I tried using dd and that didn't work and just reformatting the USB drive to exFAT (FAT32 didn't seem to work, because the October 2018 update has a file over 4 GB, meanwhile I'm downloading April 2018). What happens is that once I boot up the PC, change the boot order and then select the drive, it just goes back to some VMware kernel OS that was still on it when I got the PC. I've tried running in legacy mode, secure boot is disabled.

Does anyone have any alternatives I could use?

Also I tried plugging the usb (formatted exFAT in to my mac and it seems to recognize it in the boot menu, so I'm starting to think it's something with my motherboard/bios settings).

  • I believe that if you can download an .ISO of the version of Windows you want, disk utility has a method of restoring a disk image to a drive, under Images > Scan Image for restore. have you tried that? Apr 3, 2019 at 20:47

7 Answers 7


The open-source package called wimlib, can also "optimize" a wim file. I managed to reduce the size bellow 4Go, my FAT32 usb thumb accepted it, and booted with success

Install wimlib via brew brew install wimlib

Copie the bigfile from the iso volume to your HD Disk (Download example by example) cp /Volumes/CCC.../sources/install.wim install.wim

Compress the file wimlib-imagex optimize install.wim --solid

"install.wim" original size: 4463411 KiB 
Using LZMS compression with 8 threads 
Archiving file data: 9 GiB of 9 GiB (100%) done 
"install.wim" optimized size: 3311533 KiB 
Space saved: 1151878 KiB

You may need sudo, because you could encounter an error like this:

[ERROR] Can't modify "/home/roger/win/sources/install.wim": Permission denied 
ERROR: Exiting with error code 71: 
The WIM is read-only (file permissions, header flag, or split WIM).

Copy the reduced file to your usb drive cp install.wim /Volumes/MYUSB/sources/install.wim

Boot up !

  • 3
    ! I'd said you a case of beer, or something!!!! This is the only working answer on the internet! :) So many others have you split the file into two parts, but then the installer doesn't work. Take note, this compacted the file to 3.96 gb, so with the next update this probably won't work as it will exceed the max size! But still you're my hero.
    – Rob
    Jan 12, 2021 at 1:06
  • 1
    Can confirm this was effective for the Windows ISOs available from Microsoft as late as yesterday. The optimization process took some time (at least an hour) to run on my MacBook Air but was successful.
    – astletron
    Feb 6, 2021 at 17:24
  • Can also confirm that as of Jun 26th this method still works. The final optimized size of install.wim for me was 3605360 KiB. Jun 26, 2021 at 23:26
  • 1
    Only problem is, how does one validate that wimlib isn't inserting anything and compromising the install? I doubt there are checksums for the resulting file available...
    – Gus
    Jul 1, 2021 at 14:05
  • Just follow the steps on this youtube link: youtube.com/watch?v=A4LgzMaYCQk - no need to compress or split anything. After a few yours, I managed to do following the steps in there.
    – Udlei Nati
    Aug 16, 2021 at 1:07

There is an open-source package called wimlib that can create, extract, and modify Windows Imaging (WIM) archives. You can install this library on macOS via Homebrew:

brew install wimlib

After that, you can use following wimlib command to split the wim file:

wimlib-imagex split /win10-iso-path/sources/install.wim /Volumes/MYUSB/sources/install.swm 3000

The 3000 means the file should be split into 3000 MB-sized chunks so it can sit on FAT32 partition.

This should work most of time. However, I heard the usb might not be bootable after copying. Hence, you can directly create Windows 10 bootable USB on Mac (Catalina example)by burning the ISO image to USB and there is no need to extract the ISO. However, you should format the USB to exFAT instead.

  • 4
    Formatting as exFAT though will render the USB non-bootable by many BIOSes.
    – Taytay
    Sep 25, 2020 at 18:02

So, I needed to use FAT32 for my BIOS to accept it, but both the April 2018 and October 2018 updates had an install.wim file that was over 4 GB (I downloaded the English international version for both, maybe other versions are different?). So I needed to split the file. Here is how I did it for anyone else who has this problem.

I found this amazing guide for it (https://www.tenforums.com/tutorials/103340-dism-split-install-wim-file.html), but it was for Windows so I had to adapt it. I used split terminal command to split the install.wim file.

split -b 3700m /Volumes/CCCOMA_X64FRE_EN-GB_DV9/sources/install.wim install.wim

This creates install.wimaa and install.wimab. I then moved all the ISO files to the FAT32 USB, but with the new install.wim files. This time, when I booted from the USB, I get the Windows boot media, but it obviously cannot find install.wim. So I go to the command prompt and follow the guide and type out the diskpart commands it says (I followed MBR).

After that, I copied the contents of the USB drive to the Windows 10 volume that I created from the guide (I think I used xcopy, but there's other commands for it). Navigated to that volume, went to the sources folder and typed the commands:

type install.wimaa install.wimab > install.wim 

(Once that finished, I deleted the old wimaa and wimab files)

del install.wimaa
del install.wimab

After this I followed the rest of the guide, applied the image, add boot records (The disk volumes for me were different than what the guide should have given me, but that might have been a mistake on my part) and booted my pc back up after removing the USB. If it says operating system not found, this worked for me: https://www.wintips.org/fix-operating-system-was-n0t-found-error-on-windows-10-8-solved/.

This was so complicated for some reason and took me many hours to figure out.

  • 1
    The shrink value of 450 is not large enough. You are basically creating a partition that will remain empty. I would recommend a value of 800. The Dism /apply-image ... command defaults to the first image. You should use the command Dism /Get-ImageInfo ... to list all the images and choose the correct integer for /index. Apr 4, 2019 at 14:10
  • 1
    type command should be cat Jan 30, 2020 at 15:11
  • This was great and super helpful! Only issue was you're in the wrong country -- GB. This guide would work better for me if you hopped over the pond to US. Thanks.
    – Dustin
    Dec 11, 2020 at 18:24

I found the only way for me to make it work was installing windows on VirtualBox, and then use Rufus in the virtual machine to create the bootable usb drive. A bit tedious but it works.


It sounds strange, but you can use simply two USB sticks, but without any terminal and brew magic:

  1. Format both USB sticks using macOS Disk Utility, USB stick A (>2 GB) with FAT32 and USB stick B (>8 GB) with exFAT.
  2. Download the Windows 10 ISO and open it with macOS Finder.
  3. Copy everything except sources folder onto USB stick A (drag and drop).
  4. On the same USB stick A, create a folder called sources, and copy into it only the file boot.wim from the sources folder of the ISO
  5. Copy everything from the ISO onto USB stick B.
  6. Plug both USBs into the PC.

The computer boots from USB stick A and uses the missing files from USB stick B.

  • 1
    This worked for me.
    – aadarshsg
    Jul 9, 2021 at 13:06
  • Did not work at all. The USB stick A doesn't appear as bootable
    – JBernardo
    Oct 17, 2022 at 19:43

Microsoft offers two different methods of downloading Windows. The first is a simple download of an ISO file. The second method requires the download of a MediaCreationTool1809 application which then downloads Windows and installs to a FAT32 formatted USB flash drive. Since the MediaCreationTool1809 application requires Windows to execute, you can not use this method if you are running macOS. I suppose one could install a free copy of VirtualBox, then download the ISO. After creating a Windows virtual machine from the ISO, one could download and execute the MediaCreationTool1809 application in the virtual machine to create a USB Windows installer.

The files downloaded in the ISO by the first method are not the same as the files downloaded when the second method uses the MediaCreationTool1809 application.

As you already stated in your question, the ISO contains one file that is too large to fit on a FAT32 formatted flash drive. While ExFAT formatting can solve this problem, not all PC's can boot from ExFAT formatted flash drives. (However, newer Macs can boot fro ExFAT formatted flash drives.)

The English 64 bit April 2018 update does not have any files that would not fit on a FAT32 formatted flash drive. Below is the SHA Checksum of the file I used.

$ shasum -a 256 Win10_1803_English_x64.iso
2a7e8c918347f36c23dcbab9804aca5b88eaf8b118c7356b1d96ab771ecb017f  Win10_1803_English_x64.iso
  • I tried again with the april 2018 update and it still said it was too big.
    – ExG
    Apr 4, 2019 at 0:53
  • I did not have any trouble copying to a FAT32 formatted flash drive. Perhaps your flash drive was not large enough? Or, maybe you are using a different ISO file. I updated my answer to document the file I used. Apr 4, 2019 at 2:30
  • I got the english international version, could that be the difference? Also the .iso file says it's 4.6gb but the install.wim is 5.3gb. Anyway I found a way to work around it, going to edit my post.
    – ExG
    Apr 4, 2019 at 12:47

WinDiskWriter is an open source free tool to make from macOS a bootable USB drive with Microsoft Windows.

  • available for Mac OS X Snow Leopard up to the latest macOS Sonoma.

This application will format the flash drive for you and record an image from any of the following versions of Windows:

  • Windows 11
  • Windows 10
  • Windows 8.1
  • Windows 8
  • Windows 7
  • Windows Vista

The main advantages of this software:

  • Automatically splits install.wim into parts (if required).
  • Can patch Windows 11 image in order to remove TPM and Secure Boot requirements

Please note: I am the only developer (TechUnRestricted) of this software. For any questions, you can contact me in the Issues section on GitHub.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .