0

I am using automount to mount a set of network shares on my macbook. My problem is that when these shares are not available, e.g. when I am out of the office using a different network, I cannot login to my mac. The login screen progress bar stays stuck forever (I've let it go well over 12 hours to test).

Currently, my /etc/auto_master looks like

#
# Automounter master map
#
+auto_master        # Use directory service
/net            -hosts      -nobrowse,hidefromfinder,nosuid
/home           auto_home   -nobrowse,hidefromfinder
/Network/Servers    -fstab
/-          -static
/-  auto_smb    -soft,noowners,nobrowse,rw

Network shares are mounted in the /etc/auto_smb map file, which looks like this:

/mount/mnt1 -fstype=smb ://<user>@<server>
/mount/mnt2 -fstype=smb ://<user>@<server>
/mount/mnt3 -fstype=smb ://<user>@<server>
/mount/mnt4 -fstype=smb ://<user>@c<server>

I am certain that automounter is the source of the problem, because if I comment out the last line of /etc/auto_master, I can log in normally no matter what network I am using.

Is there any way I can fix this so that automount fails gracefully on login when the mounts are not available?

I am using macOS Mojave 10.14.3

  • Firstly, welcome to Ask Different! :) I hope you come to find this site has a lot to offer! In case you haven't already, it's worth taking the time to read the tour. All the best with your question! – Monomeeth Apr 1 at 23:06
2

I have exactly the same problem. I follow the exact step described here: http://blog.grapii.com/2015/06/keep-network-drives-mounted-on-mac-os-x-using-autofs/

/Users/username/Desktop/Synology  auto_nas

Then I created the /etc/auto_nas with entry like the following

DSVideo -fstype=smbfs ://username:password@nas/video
DSPhoto -fstype=smbfs ://username:password@nas/picture

This creates a "Synology" folder on my Desktop with a DSVideo and DSPhoto subfolder which icon looks like a mounted disk as a subfolders.

It was working flawlessly with El Capitan MacBook Pro, however when I do the same with my iMac with Mojave 10.14.4, I experienced the same issue similar with yours in which my Mac would locked up just after login while loading Finder in which I could not launch any other applications.

I saw a silver lining after I read your post. It seems that adding nofail was able to prevent our Mac from being locked out if it fails to mount.

/-  auto_smb    -soft,noowners,nobrowse,rw,nofail

Now come to my suggestion for a possible solution. I have been reading forums for many many days. Can you try the following which might help you to mount your network drives?

Have you changed the ownership of your auto_smb to root access only?

sudo chmod 600 /etc/auto_smb

Have you followed this recommendation from Apple to disable a security feature so that you can connect without providing additional confirmation? https://support.apple.com/en-us/HT207112

sudo defaults write /Library/Preferences/com.apple.NetworkAuthorization AllowUnknownServers -bool YES

Alternatively, you can follow this instruction https://gist.github.com/rudelm/7bcc905ab748ab9879ea

So instead of just using the following in your auto_smb:

/mount/mnt1 -fstype=smb ://<user>@<server>

You can add:

/mount/mnt1 -fstype=smbfs,soft,noowners,nosuid,rw ://username:password@<server>

Please let me know whether any of this works for you? Thanks.

1

Try this:

/-  auto_smb    -soft,noowners,nobrowse,rw,nofail
  • I tried added the nofail option to /etc/auto_master. This does successfully complete booting, but fails to mount the drives when the network is available. I also do not see nofail in the man pages for either mount or mount_smbfs – fergaljd Apr 2 at 17:46
  • @fergaljd: I never expected that my answer would resolve the issue that's preventing your shares from being mounted! Your question was Is there any way I can fix this so that automount fails gracefully on login when the mounts are not available? That's the question I've answered. RE the nofail option, it is one of the options in the "fourth field" of fstab entries. Unfortunately, Apple has not done a thorough job with their man documentation, and it's not listed in the macos version of man fstab. So yes, it is not documented by Apple. – Seamus Apr 2 at 20:13
  • Oh yes, I understand that. My issue with the nofail option is that it always fails to mount the drive when included, no matter if it is available or not. I suspect that is because it is not implemented by Apple's version of fstab. – fergaljd Apr 3 at 21:51
  • Please try reading some documentation before assuming such a thing! The nofail option means that a failure to mount will NOT STOP THE BOOT PROCESS. That is what you said your problem was. Again, nofail WILL NOT CORRECT your mount problems. Good luck with your problem. – Seamus Apr 3 at 22:22
  • OK, I think you are not paying attention to my response. Including nofail does allow the computer to boot, but including nofail means that the drives are never, ever, ever successfully mounted, even when they should be. Including the nofail option means that the automounter is not able to mount the drives ever, even when it should. Basically, nofail is not a valid option in any situation, which is highly likely to be the reason it does not exist in the documentation. – fergaljd Apr 4 at 22:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .