0

2011 MacBook Pro Mac OS X high Sierra, made all security and system updates.

One morning (no spills no drop) my trackpad was unresponsive the keys were mostly unresponsive, I’d hit them like 5 times and maybe get a letter to type. A few minutes later, nothing didn’t work again.

External keyboard and mouse work.

Tried smc, PRAM, tried going into safe modes, tried restarting via disk mode, safe modes, replaced the trackpad, ran an extensive hardware test with it claiming no issues with hardware, cleaned out the inside of the laptop.

Areas of concern: When I go to system preferences -> trackpad it says no trackpad found.

Hardware test in internet recovery mode said no errors (control d) (D on startup) hardware test said initializationfailed: unable to run diagnostics. DEC500 try running applediagnostics again. If the issue persists contact Apple support.

So I’m at wits end on what to do and wasn’t sure if there are other options I could use to fix the software so this works again.

Thank you for ANY suggestions and a super thank you to anyone who can find a solution to this pain of a problem.

  • Welcome to AskDifferent. Never mind the funny look on April fool's day ;) So, are you saying in ctrl+D recovery mode the internal peripherals work and in pressing only D recovery it doesn't? – n1000 Mar 31 at 13:45
  • Thanks! Yes exactly. I tried only D and it does the same errors each time. However control d tried on fast check and slow check and always no errors. Thank you – Dylan777 Mar 31 at 14:44
  • So apart from passing the test you can also use them to navigate? – n1000 Mar 31 at 15:46
  • Sorry for the late response, I’m not 100% sure what you mean by navigate but they do not work in the mode at all. I ran the test with a mouse and external windows keyboard. But the Mac keyboard worked to at least load the Ctrl D – Dylan777 Apr 5 at 6:06

You must log in to answer this question.

Browse other questions tagged .