8

I'm trying to connect to my home Wi-Fi. When I enter the correct password, I get the message

The Wi-Fi network requires a WPA2 password

I verified the password is correct in my router configuration.

I am using a 2017 MacBook Pro, running macOS Mojave 10.14.2.

I restarted my modem/router combo, restarted my MacBook, tried removing the home Wi-Fi and re-adding it (under System Preferences ā†’ Networks ā†’ Advanced ā†’ Preferred Networks), and changed the Wi-Fi password. Nothing works. My Wi-Fi name (SSID) doesn't have any special characters either.

I have another 2015 MacBook Pro and an iPhone that can connect to my home Wi-Fi with no problems. So, it seems issue seems to be particular to this device (the 2017 MacBook Pro) in combination with my home network. This device has no problems connecting to other Wi-Fi networks (it works successfully at my office, at the airport, other homes, etc.)

How do I resolve it?

  • Please instead add your "update" as an actual ANSWER on this question! Answers shouldn't be edited in to the question. – pkamb Sep 9 at 17:09
2

I had the same issue like you and I found a solution. In my case I have connected a USB 3.0 hub to my 2018 Mac mini, so macOS adds this hub like other network settings.

If you disconnect you hub or another device that macOS detects like a network port, the WiFi works fine, but to remain connected with the hub or some device, go to System Preferences/Network and set inactive the devices that show this window (USB, Hub, Thunderbolt, etc.), and with this now my WiFi works fine.

| improve this answer | |
  • Thank you!!! I tried this, and it seems to have helped. – user2895209 Sep 9 at 13:12
5

I just had the same issue. The answer I found online said to go to system preferences, then network, then click advanced and then click TCP/IP and click the Renew DHCP Lease; but I don't think that did anything.

However, instead of clicking TCP/IP, stay on the Wi-Fi page (or go back to it by clicking the tab) and click the + button to add the network. You need the network name and password, and for security I chose WPA2 personal. Apply or Click OK and that should do it. It worked for me and now I get connected automatically.

| improve this answer | |
  • Man! William! You are a total lifesaver! – shramee Dec 29 '19 at 15:02
4

I'm betting the same SSID used a different encryption mechanism previously.

Go to System Preferences ->Networks ->Advanced and remove the SSID from "Preferred networks" by selecting and clicking "-"; Turn off "Remember networks this computer has joined"

Then reboot, go to the Wi-Fi icon in the menubar (top right of your screen), select the SSID when it comes up. Enter your password and hopefully all will be well.

If that doesn't work, please try changing the SSID on your Wi-Fi modem/router, being certain that the SSID is unique. While you're at it, upgrade to 10.14.4 since there were a few, seemingly unrelated, Wi-Fi issues corrected.

Please do share what your SSID is. I'm betting your machine has "remembered" another Wi-Fi network with the same SSID, but different encryption method.

| improve this answer | |
  • Hey changing the SSID (network name) fixed the issue for me. For more information if it helps others, I had both a 2.4G network and 5G and the password issue was only happening on the 5G network. I removed the 2.4G network, and removed an ampersand that I had in my previous SSID. I think only changing the SSID was what was needed, but figured I'd share all background too. – Nic Scozzaro Apr 4 at 15:42
  • Edit: Ugh I take it back. It stopped working again 20 minutes later with the same problem. – Nic Scozzaro Apr 4 at 16:23
4

I don't know if you've resolved your issue but this is how my problem was resolved.

I have a BT Homehub router so the settings (in "advanced" tab) allowed me to 'separate' the 2.4GHz and 5GHz channel settings which resulted in 2 SSIDs being visible on the network. The 5GHz channel was recognisable from the addition of "-5" being added to my original SSID. I connected to the 5GHz channel without any problem.

It seems my issue was an inability for my MacBook air to connect to the 2.4GHz channel.

Hope it works for you too!

| improve this answer | |
  • I turned off my 2.4 GHz channel and was able to finally connect my MacBook Air back to the network. My TP-Link Deco network doesn't let me separate the channels so I'm hoping it'll stay connected now that I've turned 2.4 GHz back on. Thanks for the tip – Eric William Smith Jun 17 at 17:20
1

I am suddenly getting this problem with hardware that has been fine for a couple of years. It was fine after the recent software update, so Iā€™m concluding this is a hardware issue.

| improve this answer | |
0

Open Activity Monitor

Search for SystemUIServer in the CPU tab

Click on "On Top corner having the cross button". Force quit it

enter image description here (X)"

| improve this answer | |
0

I found the solution after I could not find anything online and even Apple senior support staff did not know. Just perform the following two resets:

Reset NVRAM or PRAM on Mac

How to reset the SMC of your Mac

| improve this answer | |
0

I had the exactly same issue with my brand new Asus Router RT-AX58U supporting WiFi 6 mode and was not able to connect to my network on the 2.4 Ghz band on my MacBook Air running High Sierra 10.13.1. All my windows and android devices had no issues with connectivity. I had tried changing WPA2 to WPA2/WPA mode and from AES to TKIP encryption, forgot network in Mac Wifi settings, but nothing was helping. Then by chance I had found a similar post about WMM and the key was to set Enable WMM No-Acknowledgement to Disable and everything started to work like a charm. This option turned out to be essential for successful 2.4Ghz network association on Asus Mac routers. My advice is to play around with the WMM (Wifi Multimedia) settings of your router so see if it will help. enter image description here

| improve this answer | |

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .