I'm trying to connect to my home Wi-Fi. When I enter the correct password, I get the message

The Wi-Fi network requires a WPA2 password

I verified the password is correct in my router configuration.

I am using a 2017 MacBook Pro, running macOS Mojave 10.14.2.

I restarted my modem/router combo, restarted my MacBook, tried removing the home Wi-Fi and re-adding it (under System Preferences → Networks → Advanced → Preferred Networks), and changed the Wi-Fi password. Nothing works. My Wi-Fi name (SSID) doesn't have any special characters either.

I have another 2015 MacBook Pro and an iPhone that can connect to my home Wi-Fi with no problems. So, it seems issue seems to be particular to this device (the 2017 MacBook Pro) in combination with my home network. This device has no problems connecting to other Wi-Fi networks (it works successfully at my office, at the airport, other homes, etc.)

How do I resolve it?

  • 1
    Please instead add your "update" as an actual ANSWER on this question! Answers shouldn't be edited in to the question.
    – pkamb
    Commented Sep 9, 2020 at 17:09

11 Answers 11


I had the same issue like you and I found a solution. In my case I have connected a USB 3.0 hub to my 2018 Mac mini, so macOS adds this hub like other network settings.

If you disconnect you hub or another device that macOS detects like a network port, the WiFi works fine, but to remain connected with the hub or some device, go to System Preferences/Network and set inactive the devices that show this window (USB, Hub, Thunderbolt, etc.), and with this now my WiFi works fine.

  • 1
    Thank you!!! I tried this, and it seems to have helped. Commented Sep 9, 2020 at 13:12
  • It didn't work for me.
    – Koro
    Commented Aug 13, 2022 at 12:56

I'm betting the same SSID used a different encryption mechanism previously.

Go to System Preferences ->Networks ->Advanced and remove the SSID from "Preferred networks" by selecting and clicking "-"; Turn off "Remember networks this computer has joined"

Then reboot, go to the Wi-Fi icon in the menubar (top right of your screen), select the SSID when it comes up. Enter your password and hopefully all will be well.

If that doesn't work, please try changing the SSID on your Wi-Fi modem/router, being certain that the SSID is unique. While you're at it, upgrade to 10.14.4 since there were a few, seemingly unrelated, Wi-Fi issues corrected.

Please do share what your SSID is. I'm betting your machine has "remembered" another Wi-Fi network with the same SSID, but different encryption method.

  • 2
    Hey changing the SSID (network name) fixed the issue for me. For more information if it helps others, I had both a 2.4G network and 5G and the password issue was only happening on the 5G network. I removed the 2.4G network, and removed an ampersand that I had in my previous SSID. I think only changing the SSID was what was needed, but figured I'd share all background too. Commented Apr 4, 2020 at 15:42
  • 1
    Edit: Ugh I take it back. It stopped working again 20 minutes later with the same problem. Commented Apr 4, 2020 at 16:23

I just had the same issue. The answer I found online said to go to system preferences, then network, then click advanced and then click TCP/IP and click the “Renew DHCP Lease”; but I don't think that did anything.

However, instead of clicking TCP/IP, stay on the Wi-Fi page (or go back to it by clicking the tab) and click the + button to add the network.

You need the network name and password, and for security I chose WPA2 personal. Apply or Click OK and that should do it.

It worked for me and now I get connected automatically.


This is how my problem was resolved.

I have a BT Homehub router so the settings (in "advanced" tab) allowed me to 'separate' the 2.4GHz and 5GHz channel settings which resulted in 2 SSIDs being visible on the network. The 5GHz channel was recognisable from the addition of -5 being added to my original SSID. I connected to the 5GHz channel without any problem.

It seems my issue was an inability for my MacBook Air to connect to the 2.4GHz channel.

  • I turned off my 2.4 GHz channel and was able to finally connect my MacBook Air back to the network. My TP-Link Deco network doesn't let me separate the channels so I'm hoping it'll stay connected now that I've turned 2.4 GHz back on. Thanks for the tip Commented Jun 17, 2020 at 17:20

I am suddenly getting this problem with hardware that has been fine for a couple of years. It was fine after the recent software update, so I’m concluding this is a hardware issue.


I had a similar problem noted herein. I had tried all above with no luck.

It then occurred to me that sometimes the KeyChain for a given password (in this case to the SSID on my router) gets corrupted or some such problem.

So I went into KeyChain, deleted the entry for the SSID for my router, and then all was well; upon netr trying to login using that SSID, I could once get in again.


I had the exactly same issue with my brand new Asus Router RT-AX58U supporting WiFi 6 mode and was not able to connect to my network on the 2.4 Ghz band on my MacBook Air running High Sierra 10.13.1.

All my Windows and Android devices had no issues with connectivity.

I had tried changing WPA2 to WPA2/WPA mode and from AES to TKIP encryption, forgot network in Mac Wifi settings, but nothing was helping. Then by chance I had found a similar post about WMM and the key was to set Enable WMM No-Acknowledgement to Disable and everything started to work like a charm.

This option turned out to be essential for successful 2.4Ghz network association on Asus routers.

My advice is to play around with the WMM (Wifi Multimedia) settings of your router so see if it will help.

enter image description here

  • Could not get my brand new Asus router to work with MacBook Pro running macOS 12. I thought it was a WPA3 or 802.11ax compatibility issue but no. Switching this option off instantly fixed the issue.
    – dragon
    Commented Feb 11, 2022 at 21:50

I found the solution after I could not find anything online and even Apple senior support staff did not know. Just perform the following two resets:


Open “Utilities > Activity Monitor.”

Search for “SystemUIServer” in the CPU tab.

Click on to left side which has he cross button to force quit it.

enter image description here


This is what worked for me: My router allows both 5G and 2.4G WLAN interfaces. It seems you are supposed to only set one of them with full WPA2 encryption, so you end up with 2 options:

  1. Disable 2.4G WLAN and setup 5G WLAN with WPA2 only
  2. Keep both but one of them has to be WPA/WPA2 encrypted (which is less secure)

Oddly enough, other Macs at home didn't have an issue connecting when both WLANs were full WPA2

  • Can you provide a reference for you must only set one. (I think I have have full WPA2 on both)
    – mmmmmm
    Commented Jun 11, 2021 at 21:07
  • I got none, I found this through trial and error. Also, older devices run on Broadcom firmware which is known to struggle with WPA2 networks. Perhaps check that first.
    – cdvel
    Commented Jun 13, 2021 at 3:39

I had the same problem. enter image description here

It happened today and my other devices are fine. A restart didn't solve the problem.

It turned out that Cambridge University had announced a change of certificates that I didn't pay attention to.


  1. delete the old certificate following this link (I didn't find an old certificate on my computer so I skipped this step)
  2. set up eduroam following this link. (For my university I had to create a to create a token, install a profile, and log on)

And then it worked!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .