3

I'm running macOS 10.14.4 with iCloud keychain. Safari is asking me to use touch ID or password every time I want to fill-in credentials. That wasn't the behavior since lately.

I saw some articles which advice to resent login keychain password, but that option is not available in the current version of macOS.

Is that behavior is by design or something is wrong with my security configuration?

Thanks,

Gil

2

These changes are by design, introduced in Safari Technology Preview Release 66 and promoted to Safari in macOS 10.14.4.

Password AutoFill

  • Automatically submit login forms when filling credentials with Password AutoFill
  • On MacBook Pro with Touch Bar, require authentication with Touch ID to fill passwords into web pages; this can be changed in Safari’s AutoFill preferences

https://developer.apple.com/safari/technology-preview/release-notes/

  • I see the release notes, but the AutoFill preferences do not appear to have an option to not require authentication. Only option is whether or not to fill in passwords at all. – David Mar 28 at 16:48
  • @David Maybe OP has a Touch Bar Mac – ankiiiiiii Mar 28 at 20:30
5

On Mac OS 10.14.4, go to system preferences, select Touch ID. Uncheck using Touch ID for Safari AutoFill.

It will no longer require Touch ID to autofill passwords and reverts back to earlier behavior.

  • 1
    Please note that this is the correct answer; though the accepted answer provides accurate background, its proposed solution/workaround does not exist – Peter Apr 2 at 9:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .