7

After upgrading my Mac mini to macOS Mojave 10.14.4, every time I restart the computer the process "warmd" keep busy CPU and hard disk for 10-15 minutes, with great "spooling" noise and slowing down all the finder. What's happened? Its a well known bug of the upgrade?

enter image description here

enter image description here

7

It's supposed to "warm" the cache with your most frequently accessed applications and files.

If you have a "spinning rust" disk drive instead of an SSD, I can imagine that it may hurt more than help.

On my 2017 15-inch MacBook Pro with SSD for storage, I see high CPU utilization immediately after reboot for a few minutes, but between the 8 threads and the very fast storage, I don't notice a significant slowdown.

I think warmd pretends to load each of your 10 most frequently used applications and all the files you normally have open to "warm" its caches. Theoretically this will help your machine run faster when you actually try to use those applications/files.

With an old hard disk instead of an SSD, this just gives the system a lot of busy work to do and may not be such a wise idea. Also, while an SSD can perform several reads and writes at different places on the disk with very little delay between operations, a hard disk can only do 1 thing at a time, so with thousands of requests in the queue, boot time will suffer. Please file a RADAR with Apple. I can't currently find a way to disable warmd. If you want your machine to be responsive immediately after booting, this is a step in the wrong direction, and is a serious goof on Apple's part.

  • 2
    Your explanation is very useful, what I tried to understand is WHY the warmd process pretends to do this hard "warming" only after this 10.4.4 upgrade and I have not noticed it with other upgrades. Yes, my Mac mini have not a SSD storage but honestly, just this morning, after about ten reboots since the upgrade, the machine is immediately responsive. Maybe the cache "warming" is finished :) – Huxley Mar 29 at 10:44
5

Have a read of the following;

Provisioning OSX and disabling unnecessary services

It has instructions on how to disable warmd. I can not confirm they are still relevant at this stage as I myself am installing the latest OSX as we speak. I will provide more details after that install finishes.

TL;DR

Kill warmd: launchctl kill -9 system/com.apple.warmd

Disable warmd: launchctl disable system/com.apple.warmd

  • 2
    Thank you, very interesting link to read. Unluckly the command launchctl disable system/com.apple.warmd is not working for me (under macOS 10.14.4), so I can't still disable the process. – Huxley May 13 at 9:53
  • More. I have followed this great link [github.com/drduh/macOS-Security-and-Privacy-Guide] to understand how disable processes under Mojave. So I have restarted mac in Recovery mode and disabled System Integrity Protection with csrutil disable, then I have restarted again and typed sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.warmd.plist command on Terminal. Finally, I have rebooted. No way, after 5 minutes the warmd process starts again and keeps busy the computer. – Huxley May 16 at 13:17
0

You can use a scheduling app like Scheduler for Mac to launch an AppleScript to quit warmd upon reboot. Just look for it on the internet and read its help to know how to do it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .