I'm trying to use Unity to export the app I'm creating. It gets about halfway through the process before showing the message:

"Creating directory. Creating directory Library/ScriptAssemblies failed. Please ensure there is enough disk space and you have permissions setup correctly."

There's 60GB of free space. I don't understand permissions well enough to know what to do here. I could really use some help, I only know Windows.

1 Answer 1


This problem could be solved by deleting the "library" which is generated by Unity. Unity directory is as following:

Unity > - Assets - Library <- Delete the directory, and reopen Unity - Log - ProjectSettings - Temp

On the other hand, you can see information about permissions and their errors in the following Apple website: https://support.apple.com/en-au/HT203538

  • I tried what you said. Weirdly, and I didn't know this, all the packages you download from the asset store go here and they aren't automatically redownloaded. So my scene doesn't work, I'd either have to set them all back up manually or I just copied the folder back.
    – Phedg1
    Commented Mar 28, 2019 at 11:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .