7

In MacOS Mail, we can change the background color of a message in the message list. This could happen in two ways AFAIK: (i) Select a message, go to Format -> Show Colors, then choose a color, or (ii) Setup a rule that automatically set the background color based on some conditions.

The question is: once the background color is set, I can't seem to find a way to remove the background color. I can only change it to another color. This does not work well when we switch between dark mode and light mode. What I would like to do is to remove the colors all together (or equivalently, make the background transparent). Is there a way to do this?

3
  • what happens if you select "convert to plain text" and then go back to rich text? When I do Format -> Show Colors and select a color it actually only changes the text color for me. I don't see a way to set the background color.
    – dwightk
    Mar 27, 2019 at 12:50
  • 1
    I am referring to the message list (the list showing sender, subject, date, etc) not the message body.
    – wto
    Mar 28, 2019 at 3:32
  • Not even Menubar -> Format -> Make Plain Text (shift-command-t) solves this continual vexation.
    – 2540625
    Jun 19, 2021 at 0:02

5 Answers 5

2

This solution properly satisfies the original request without work-arounds or hacks. I just found specific default "non-colors" that change with the theme:

Removes background color of a message in the message list, while preserving the re-colorization with the Light/Dark system themes.

No weird tricks. I think Apple intended for Developer colors to be used this way.

TL;DR:

If you want to remove colorization on messages use the color called alternatingContentBackgroundColor. Make a new rule to colorize messages and in the color selection dropdown list -> "Other..." -> Color Palettes -> choose "Developer" in the dropdown list -> choose alternatingContentBackgroundColor from the list. Works for both Dark and Light themes, and maintains UI consistency when switching.

How I discovered the solution:

I was struggling with this too. Had an error in one of my rules that colored the background of every message in my inbox. Then the quest to undo that mistake begins...

For clarification, I'm not concerned about the color of the email message itself, just the background color of each message in the message list column.

I'll never understand why Apple would provide a way to colorize the background of messages, but make it so hard to change or remove it... But here we are.

I'm running the Mail app on MacOS 13.3 with Dark theme. I can confirm that setting a rule to remove the color or set to "Transparent" (following previous suggested methods) didn't work. As far as I can tell, the coloring rules have no transparency support at all now.

Here's what ended up working for me:

Initially, I used the color picker on the message rule action's color selector to pick the background color of a message in the list whose background hadn't yet changed. I noticed that the color matched the "textBackgroundColor" entry in the Color Palette's Developer colors, so I selected that option. Oddly, when applied, it set a background color that was darker and didn't change with the switch between Light and Dark themes. Almost gave up there, but...

I looked at the different colors in the Developer color list and wondered if any of them might change with the system theme. This thought proved useful, as when I selected alternatingContentBackgroundColor, I noticed the color looked like it was for the light theme. I applied it anyway, and was surprised when it restored the background color of listed messages back to their un-colored state. Toggling between Dark and Light themes causes the background of listed messages to change as expected.

*Edit* for Restoring Original Text Color:

Just in case anyone comes across the same issue with setting the Text Color in the message list, I was playing around with some of the other "Developer" colors and quite a few of them are sensitive to the system's Theme.

The color you want to use to restore default (non-colorized) text that'll be compatible with your theme is: disabledControlTextColor.

To make sure I can easily restore the text or background colors of any message, I keep 2 disabled rules at the top of my rules list to match "Every Message" and Set Color of Message appropriately and stop processing any other rules (on just the 2nd rule).

To restore text and background colors, I temporarily enable those first 2 rules, then either apply rules to individual messages (option in the context/right-click menu), or apply rules to the whole folder.

Even if I forget to disable them, no harm because new messages arrive and just have their colors set when they get put into the inbox. Disabling them and rerunning rules on my inbox reprocesses the inbox against other rules again.

Hopefully this info is still relevant to help others with this issue since I'm sure most previous posters have moved on with their lives.

4

I know a year old, but for others:

  1. Open a new email.
  2. Paste a screenshot into the new email.
  3. Select markup in the top right of the screenshot image.
  4. Select a color in the markup tool and open the colours dialogue.
  5. Choose any color, but reduce the opaque to 0%
  6. Drag this 0% opaque color (transparent) to the preset slots on the right of the color dialogue.
  7. Close the dialogue and the discard the email.
  8. Make a rule in Mail that is trigged for all emails.
  9. Set the background color in that rule and select the preset with the transparent colour.
  10. Select all your emails, right click and let rules run for these emails.

Have fun.

3
  • WTF - APPLE !!! What have you done... (sad emoji)
    – TMS
    Mar 30, 2021 at 21:02
  • This does not work anymore on Big Sur (at least i could not get it to work, because the transparent color set in the screenshot chooser, was NOT transparen later on in the filter color chooser). BUT - there is an easy fix. Just go into the mail filter and make a filter for your emails, then choose as color 'snow' (if light mode is enabled, or likorize if dark mode is enabled). This sets the correct color for the current mode AND it also works automagically AFTER you switch the mode !
    – TMS
    Mar 30, 2021 at 21:30
  • This does not work for me on Ventura 13.3 - any other suggestions? Apr 3, 2023 at 17:41
0

I think I found an easier way:

  1. Quit Mail
  2. In Finder, navigate to your ~/Library/Mail folder
  3. Delete the version folder (V#)
  4. Launch Mail
-1

Answering an old answer now, but as of April 2022, highlighting/selecting a message and then hitting Cmd+Shift+C will bring up the color picker and selecting a color there will set the color of the message.

-2

I almost always use dark mode, and I find it disruptive to receive emails embedded with colored text and backgrounds (usually black on white, sometimes with yellow highlights).

While I’ve not found a way to prevent this when viewing emails, there is a way to do so when replying/forwarding.

Menubar -> View -> Message -> Show with Dark Background

The command may also appear as “Show with Light Background”.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .