1

Background: I relocated my music library to a different hard drive on my Mac. In order to sync iTunes, I exported the playlist, edited all the file paths to the new location, and imported it back into iTunes. It worked fine, except:

Now I have duplicate "most played", "most recently played", "classics" etc in the automatic playlists section in the left pane, both in iTunes and on my iPhone. (My Mac is localized to Swedish, so these playlist names are my own off the cuff translations back to English.)

I have looked at the XML playlist file I imported and could not find any entries there which would have caused the duplication, so starting over does not seem like a viable approach.

I have added album art, play times etc to the songs in iTunes so I would rather not start over from an empty music library. None of this is purchased via iTunes (and frankly I'd rather be without iTunes altogether); I have transferred my CDs to FLAC over the years and just converted them to MP4 for import into iTunes when I first got an iPod Touch a few years ago.

2

Forgive me if I'm mistaken but can't you just right/second click and hit delete?

rightclick

and then set to sync with your iPod under the music tap of the connected iPod

  • Thanks. I don't know why this didn't work before. Maybe it was enabled by a recent iTunes upgrade (I upgraded from 9.something I think). – tripleee Jan 4 '12 at 11:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .