0

My camera creates both RAW and JPEG photos. Normally I delete the JPEG photos before importing. Today I forgot to do that. Now the photos on the card are deleted, and it seems that I only have JPEG images in my Photos library.

To test this I created two smart albums, one with only RAW, one with no RAW - effectively JPEG only. The last photos are only found in RAW, not in the JPEG album. Why is that? I can't find a setting to prefer RAW either.

Why would Photos ignore the RAW files, while it's obvious that these are preferred?

  • 1
    I don't use Photos to handle my RAW images, so this is a bit of a Google... it should keep them as pairs, but it will favour the JPG. It ought to have a J top right of any image that has an associated RAW. Right click any pic & select Use RAW as Original. At least that might help us figure what happened... depending on whether you get the option do that or not... – Tetsujin Mar 23 at 19:52
  • Off topic for AD, but this is why I don't let anything other than dedicated Nikon software touch my RAWs... photo.stackexchange.com/questions/96952/… [I would apply similar logic to any camera manufacturer.] – Tetsujin Mar 23 at 19:56
  • @Tetsujin, I see the J, but not the option to use RAW as original. This article: kirkville.com/… mentions something similar, which I don't see. – SPRBRN Mar 23 at 20:07
  • That was one of the pages Google threw up. I can only speculate that for some obscure reason, it either failed to copy all, or having copied, failed to recognise the pairings. Have you tried digging in the Masters folder to find them? [Right click the Photos Library file, Show Contents] They're filed by date. – Tetsujin Mar 23 at 20:12
  • Wait, I see that I should not right click on the image. You have to edit the image, then (menu) image > Use RAW as original, then "done", and you see an R in a square on the left top. You have to do this for each image, can't do it for all at once. – SPRBRN Mar 23 at 20:12
1

If you see a J in a square on the top right of the image, you're using the JPEG image. You can change this to RAW using the following steps:

  1. Open the image
  2. Click the yellow edit button
  3. Menu: Image > Use RAW as original
  4. Click done

You will now see an R in a square instead of the J. You have to do this for each image, can't do it for all at once.

  • If I open the Photos app, none of the images displayed have an R or a J. Am I doing something wrong? – jmh Mar 24 at 16:34
  • This only happens if you import both JPEG and RAW. – SPRBRN Mar 26 at 16:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .