0

So this started happening recently, I think after the last OS upgrade. Now if I plug in an external mouse (any mouse, I've tested several) while in Windows 10, the mouse click and scroll won't work anymore. It also disables the mouseclick on the track pad. The really weird thing is that I'm able to click on icons on the desktop, once. So I can't double click them to open them, but I get that blue highlight when clicking once.

  • I've tried rebooting with the mouse Connected, and then it works for like 10 seconds. Which makes me believe some service starts up and messes everything up.
  • I've tried running msconfig to disable all non-Windows services, and then rebooting.
  • I've tried uninstalling the device from the Device Manager.

Edit: And even weirder still. If I plug in the external mouse while playing a game, not only does the mouse Works fine, it also Works fine after quitting the game. So apparently this is how I'll have to do stuff now.

Boss looks over shoulder: You playing games at work.

Me: I have to play an hour of Satisfactory for my mouse to work properly.

  • What device are you using? Which version of bootcamp/macOSX did you install Windows using? – Alex Mar 24 at 1:38
  • @Alex I'm on Mojave on OS, and Windows 10. But I installed Boot Camp on High Sierra, I think, or it might even have been on Sierra. The mouse is a Steel Series mouse. And it works perfectly well on macOS. – peirix Mar 24 at 15:34

You must log in to answer this question.

Browse other questions tagged .