1

On Safari, if I open a page with a URL and navigate to another page, Cmd-Option-8 navigates back and Cmd-Option-9 navigates forward, which is also the behavior in Finder.

But with a brand new tab and when the page does not have a previous or next page, Cmd-Option-8 opens Twitter and Cmd-Option-9 opens Linkedin.

How can I disable the shortcuts to these pre-defined websites?

  • Those aren't shortcuts at all in Safari for me. What language is your keyboard set to? – Tetsujin Mar 22 at 11:13
  • You are right: the shortcuts are Cmd-[ for back and Cmd-] for forward. My language is set to Portuguese, where Option-8 is [ and Option-9 is ]. Do you get the websites with Command-Option-8 and Command-Option-9? – miguelmorin Mar 22 at 11:15
  • Using Cmd [ & ] I just back/fwd. I get nothing if there's 'nowhere to go'. It certainly doesn't launch new pages. – Tetsujin Mar 22 at 11:18
  • I wonder if it’s executing cmd-8 and cmd-9 in a new tab with “nowhere to go” and there are pinned tabs at locations 8 $ 9 (cmd-# will switch to that numbered tab?) – samh Mar 22 at 11:25
  • 1
    @samh: I use Cmd-8 and Cmd-9, which bring me to the 8th and 9th tab open, if any are available. The problem is when I add Option in the shortcuts: Command-Option-digit. 1 goes to Apple, 2 to iCloud, 3 to Google, 4 to Yahoo, 5 to Bing, 6 to Wikipedia, 7 to Facebook, 8 to Twitter, 9 to Linkedin, and 0 is not assigned. – miguelmorin Mar 22 at 11:38
2

By default (on my Mojave installation, at least), Cmd+Option+# triggers Safari to load the #th Favorite Bookmark. E.g. if you View > Show Favorites Bar, you will see that Twitter and LinkedIn are the 8th and 9th bookmarks. I would show the favorites bar and remove what you do not use.

  • 1
    Yes, this is it. Removing the favorites fixed the problem. – miguelmorin Mar 22 at 14:51

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .