2

I have a 2015 MacBook Pro on the latest version of High Sierra. I often use a USB microphone for Skype, etc. When I plug in the microphone, my Mac automatically detects it as an input source. This is good. However, it also automatically detects it as an output source, which is not good at all, since the microphone has no output capabilities. Every time I plug in the microphone, I have to go to Sound preferences and unselect it as the output.

picture of sound menu How can I stop my Mac from automatically detecting my microphone as an output source — while continuing to have it automatically detect it as an input source?

  • Is your microphone a headset with an earphone as well? – Tony Tellez Mar 21 at 0:31
  • Did you figure this out? I'm having the same issue with a headset that I don't want to automatically be selected as input device, so I manually have to unselect it.. – Sti Aug 5 at 9:50

You must log in to answer this question.

Browse other questions tagged .