2

I tried to start my Mac & a folder with a question mark appeared.
I researched on Google and discovered it was a problem with the Boot partition. I saw how to fix it. I used Opt ⌥ while booting and I was able to get to Mac Internet Recovery.

I tried to install new software, after agreeing to terms and conditions, it took me to the next screen where I had to choose the Install destination. But it was blank - There was no Macintosh HD hard disk icon present there.

No Hard Disk to select

enter image description here

enter image description here

When I went to Disk Utility, There was no Macintosh HD there either. When I researched on SE, one similar questions was asked - the solution said that there would be a drive named super disk. But here in my Mac there is no super disk. Only a single disk 2 GB drive.

I understand the disk may be dead but it could be also because of a loose connection as I recently opened my Mac.

Update (5 Months after asking question): When the Genius Bar took a look at it, they found out that the disk had died. I got it replaced and now it works perfectly.

  • 1
    "Super Disk" is the name of the DVD. Which Mac are you using? What version of macOS? – Allan Mar 19 at 12:33
  • If you open Disk Utility from the Tools menu in the installer and nothing shows up there either then the drive has (possibly) died. Or there is another issue like cables or connectors to/from the HD. In that case time to take it in for service. – Steve Chambers Mar 19 at 14:24
  • What do you mean by died @Steve Chambers – Sarvesh Thiruppathi Mar 19 at 14:33
  • 2
    Its passed on! This hard drive is no more! It has ceased to be! Its expired and gone to meet its maker! Its a stiff! Bereft of life, it rests in peace! (With apologies to Monty Python) – Steve Chambers Mar 19 at 14:36
  • Soo... It's in heaven ? Lol , I understand what you mean but it could be also because of a loose connection as I recently opened my Mac. – Sarvesh Thiruppathi Mar 20 at 1:02
1

Follow this guide on how to erase and install Mojave and all recent macOS releases. Many old instructions on the net are wrong.

You create the Macintosh HD as part of the process, so if it’s not there either you aren’t taking the intended action or there is a failure in the disk (hardware) and Disk Utility should throw an error condition to trace that.

Follow the link on erase in step 2 above for the erase portion.

  • I have updated the question and posted a photo. That's what happend. – Sarvesh Thiruppathi Mar 19 at 13:36
  • Great Photo @SarveshThiruppathi - I’m more sure that you can still follow the guides above. Specially the second one explaining you have to choose APFS or Extended. In your case - with Sierra you are forced to choose Extended. What happens when you repartition your drive? If that fails - seek hardware service or try installing on to an external USB / ThunderBolt drive. Apple can install to external drives and that’s the easiest way to troubleshoot an internal drive failing - by not opening the case until you have to. – bmike Mar 19 at 17:57
  • Ok I will try and let you know. And thanks for your help. I suspect it might be because of a loose connection to the hard drive as I recently opens my Mac to repair it. – Sarvesh Thiruppathi Mar 20 at 1:00
  • I have updated the questions with 2 more photos. I didn't have a disk itself – Sarvesh Thiruppathi Mar 20 at 9:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .