1

I have a 2015 iMac that no longer boots. I want to recover the ~1 TB of data on it and transfer to a brand-new iMac. (Through a comedy of errors, my Time Machine drive isn't available.)

I can connect the two machines via Target Disk mode with a Thunderbolt cable/Thunderbolt 2-to-3 adapter. I tried Migration Assistant, and it recognized the old drive and offered to transfer, but I let it run all weekend and it didn't get off the first step ("Looking for applications and documents to transfer ... "). I tried a few variants, such as only migrating one user account and only migrating Settings (as a test) and all of them hang on the first step.

I can look at the Target Disk on the network and see the user accounts with the appropriate amounts of data on them, but I don't have access to the files because it doesn't have permissions.

How can I give the Target Disk the appropriate permissions? Can I enter the password somewhere?

A possible complication is that the old iMac login was via a network user account. I know the various passwords, but I'm not clear on whether the old iMac, now no longer able to access the network, will know them.

My overall question is how to recover the data from the old iMac; if there's a simpler way than connecting via Target Disk mode, entering the appropriate permissions, and copying files to the new machine, that would be welcome too.

1

I did an almost identical recovery a couple days ago. Heres my answer:

DON'T USE MACOS BUILT IN TRANSFER METHODS

I have found them extremely unreliable, difficult to debug, and unable to resume on failure.

Instead, use rsync!

Connect via Target Disk Mode. Make sure to ignore permissions on the drive.

The following command will recovery everything and preserve metadata including dates, etc. It works extremely well, is able to resume on failure, and shows progress.

/**
  *
  *  /path/to/source - Path to the disk you want to recovery (or a folder on it if you only want specific things)
  *  /path/to/destination - Path to disk you want the items to be copied to
  *
  */

 rsync -avP /path/to/source /path/to/destination

It will take a while to count files but you will see it counting.

To continue - https://unix.stackexchange.com/questions/67539/how-to-rsync-only-new-files

  • rsync was complaining about many "invisible files", which I think indicates a drive on the verge of, or past, failure - the drive was in target disk mode so there should be any temp files. However, sudo cp -pr seems to be working reasonably well, with rare file input/output errors that may also indicate bad drive sectors. – iayork Mar 19 at 12:43
  • @iayork What was the exact error from rsync if I may ask? If cp is working then use that. First priority is getting these files recovered ASAP. – JBis Mar 19 at 12:44
  • It's the "file has vanished: " warning. From my searches, this is expected to happen with system files or tmp files that are indexed and then disappear, but shouldn't be happening with "real" files as I saw. Agree that as long as cp is working my priority is to move things over to a reliable drive and I can deal with permissions issues etc later, if need be – iayork Mar 19 at 12:48
  • @iayork Yeah, sounds like corruption. After you recovered everything, I was suggest reformatting the drive (not just the partition). See if that helps. It most likely wont, but worth a try. – JBis Mar 19 at 12:51
  • Pretty sure it's dead - it was gradually throwing more and more errors, and multiple fsck runs didn't help at all. Even if formatting the drive brought it back up I would not trust it with data, so it's not really any use to me. – iayork Mar 19 at 12:52

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .