2

I use an iMac with Target Display Mode from a Macbook Pro. Sometimes when I enable Target Display Mode, the iMac screen stays black, even if my Macbook Pro's display suggests that another monitor has been plugged in (apps move away from the screen).

How can I fix this?

2
  • Posted my answer in a similar thread here. Hope this helps. – debuggr Jun 8 '19 at 17:05
  • 1
    It's worth noting that, per the linked KB article, "Target display mode requires macOS High Sierra or earlier. It does not work with macOS Mojave or later.", and, "This article has been archived and is no longer updated by Apple". So they retroactively removed this feature, and its reliability is just going to get worse and worse over time. It's a real bummer. – Glyph Apr 11 '20 at 0:39
2

On the Macbook, change the rotation on the iMac display to 90°, then revert it back (or let it revert back after the timeout) to Standard. That seems to snap it out of its zero-brightness funk more or less every time much more frequently than other display changes.[1]

(Of course, you can't do this in clamshell mode, you need some functioning display to use System Preferences→Displays on.)

[1]: (I've seen it fail once or twice, but it is the most reliable workaround I've found yet.)

3

On closer inspection, it looks like the display is not actually uniformly black. This led me to conclude that perhaps the backlight was just not turned on properly, and led me to discover the following workaround:

  1. Log into the iMac
  2. Change the brightness to a different level (e.g. up or down by one). The level seems to need to be different from the one previously used.
  3. Enable Target Display Mode again, by pressing Command+F2
11
  • 2
    This doesn't seem to work super reliably for me. For while it seemed like it did, but I'm trying to get TDM to kick in right now and it's just black no matter what buttons I press. – Glyph Oct 12 '19 at 22:54
  • @Glyph just coming across this issue now and so far the only fix I've found is to log out of the account on the iMac so I'm at the login screen before hitting command+F2. Would be interested to hear if the same works for you – CupawnTae Oct 13 '19 at 16:23
  • 1
    @CupawnTae Logging out on the iMac doesn't work at all; it just doesn't recognize ⌘-F2, won't go into TDM at all on the login screen. However, I have found another workaround which seems reliable: on the macbook, change the rotation to 90°, then revert it back to Standard. That seems to snap it out of its zero-brightness funk more or less every time. (Of course, you can't do this in clamshell mode, you need some functioning display to use System Preferences→Displays on.) – Glyph Oct 15 '19 at 4:27
  • 1
    Oh my goodness, the screen rotation workaround worked for me. – m01 Nov 5 '19 at 9:14
  • 1
    @m01 Done. Words words words because SO has a minimum comment length. Words. – Glyph Nov 5 '19 at 22:14
0

Resolved. Had to uncheck 'Automatically adjust brightness' on the iMac's display control.

1
  • I hoped the fix would be this easy, but it didn't work for me. – jbnunn May 13 '20 at 15:07
0

So for those of you who still have this problem and nothing above helps.

It only worked for me only after logging the user out on the iMac.

  1. You log off
  2. Press CMD + F2 (sometimes you need try it two times)

But logging off the user every time I want to use the imac in a target display mode is quite annoying. I found another option which works for me:

  1. Lock iMac (CMD + CTRL + Q)
  2. On the login screen of the imac click: "Switch users"
  3. The list of users should appear on the screen of the iMac
  4. Now press CMD + F2
  5. It usually does not work from the first try. So if the screen of the iMac is just black, press CMD + F2 to exit "target screen". And then press CMD + F2 once again. Always works for me from the second try and does not require a user to be logged off from the imac.

Hope this helps

0

I posted this on another question, not sure how to link it so adding again here.. I use 2009 iMac as an external monitor to my 2015 MBP.. all running latest supported OS as of today.

COMMAND-F2 on the iMac keyboard will toggle between the running iMac local display, and the Target Display Mode (TDM) when connected to my laptop via DisplayPort. TDM always starts out at 100% brightness when you switch to it.

COMMAND-F1 will adjust brightness lower until it goes completely dark. If that happens you need to switch back to iMac local display then return again to TDM which resets to 100%

Now the important part: COMMAND-F1 sometimes doesn't respond to lower the brightness. I found this seems to happen if local iMac screen is locked.. if I switch back to local iMac display and log in to the account to unlock it, then when I switch back to TDM, the brightness control will now respond.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .