0

Problem:

I was watching a movie through iTunes and 20 minutes in the movie just stops and says it can't find the file location. I recently moved my iTunes library to my external drive, but I watched a complete movie the other day and had no issues. When I looked for the drive on my computer it showed that it was no longer mounted.

What I tried:

I tried repeatedly unplugging and replugging it in but it wouldn't mount at all. I also opened the Paragon software but when I told it to mount the drive it got stuck thinking and had to force quite. The same thing happened when I tried checking the 'Open in read only mode' box. When I checked Disk Utility it shows up but is greyed out and says it is not mounted. The First Aid and Partition buttons at the top are also greyed out but the Erase, Restore and Mount buttons are useable, however when click Mount nothing happens (no spinning wheel or anything). As far as I can tell, no updates occurred at the time of the issue. Also, I was able to access the drive through my blueray player and through an old PC with Windows Vista on it.

I came across a variety of issues people had with NTFS drives not mounting but they were all when they first tried to mount it, not while the drive was already in use.

Any suggestions on what would cause this type of issue and how to fix it?

Update: While typing this questions out the drive spontaneously mounted after being plugged in for about 10 minutes with nothing happening. Since I don't know what caused it to unmount or remount I don't know that the problem is actually fixed so I'm still posting this question.

You must log in to answer this question.

Browse other questions tagged .