0

I hope someone can advise please...

A few days ago I had to restore my whole system from Time Machine backup after a power outage stopped my Mac from booting up. Everything seems fine, except for Safari.

Safari now won't load any web pages, it just shows a message at the top: "this webpage was reloaded because a problem occurred". Other browsers are fine.

My MacOS is High Sierra 10.13.6

Safari version is 12.0.3

I have read other pages that suggest that maybe when I was restoring, that the newest version of Safari might have downloaded via "automatic updates" from the App store, but I don't know (a) what version of Safari I had before, and (b) whether Safari 12.0.3 is meant to be OK with High Sierra 10.13.6?

Any clues or advice welcome!

2 Answers 2

1

This could be a problem with the wrong version of Safari, or it could be a problem with its cache or preference file.

Start by deleting the cache folder, located here:

~/Library/Caches/com.apple.Safari/

If that doesn't work, delete the preference file here:

/Users/sklein/Library/Preferences/com.apple.Safari.plist

If the problem persists, delete Safari (by dragging it to the Trash), then reinstall macOS High Sierra from Recovery.

The reinstall will take a while, but you won't lose any apps or data.

2
  • Or you could just clear the cache "Clear history..." from the Safari menu and then (if needed) apply the latest combo update which usually updates Safari. Commented Mar 13, 2019 at 22:47
  • Thanks for the suggestions so far.
    – DavetheCat
    Commented Mar 14, 2019 at 14:30
0

Thanks for the suggestions so far.

I have already tried clearing cache, but that didn't help. I tried to go into Safari Preferences - but as soon as I click on the Preferences option Safari quits (I get a "Safari quit unexpectedly" box).

Sorry to sound dim but how do I get to the files "~/Library/Caches/com.apple.Safari/" and "/Users/sklein/Library/Preferences/com.apple.Safari.plist" ?

And again - this may be a dim question but how /where would I apply the "latest combo update" - do you mean from App store?

Thanks for any further advice (and for your patience with a newbie!)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .